summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBioArchLinuxBot2024-04-05 18:06:00 +0000
committerBioArchLinuxBot2024-04-05 18:06:00 +0000
commit0b33b9212290b8ec77bf61a4a9da30bda420813e (patch)
tree3034bcaa23d643d269d27dfce411ab6064fb7462
parentf1e0af6a2056046e8444aa525ecebf3e47b57b80 (diff)
downloadaur-0b33b9212290b8ec77bf61a4a9da30bda420813e.tar.gz
[lilac] updated to 1.26.0-2
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD23
2 files changed, 17 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4a952eaccc08..bd1b674fbb3b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,16 @@
pkgbase = r-pgca
- pkgdesc = PGCA: An Algorithm to Link Protein Groups Created from MS/MS Data
+ pkgdesc = An Algorithm to Link Protein Groups Created from MS/MS Data
pkgver = 1.26.0
- pkgrel = 1
+ pkgrel = 2
url = https://bioconductor.org/packages/pgca
arch = any
- license = GPL
+ license = GPL-2.0-or-later
depends = r
optdepends = r-knitr
optdepends = r-rmarkdown
optdepends = r-testthat
source = https://bioconductor.org/packages/release/bioc/src/contrib/pgca_1.26.0.tar.gz
- sha256sums = 7a1892848a5577c238184419e719247504ce82180044ae9bf7109aa133cce06a
+ md5sums = 43c58c5b347ebf060a9e6afdc8aa8e93
+ b2sums = a43e7b2f25a506f917960ab0d193f7399db2d82bd82f2e164b0eb8f9b80fc90252ab3750aaddffe31ef349252f011566f31fc6715930a272cdbe1f3b082b715a
pkgname = r-pgca
diff --git a/PKGBUILD b/PKGBUILD
index 906c85e8d0f7..5c79d2a7a8b3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,12 +3,12 @@
_pkgname=pgca
_pkgver=1.26.0
pkgname=r-${_pkgname,,}
-pkgver=1.26.0
-pkgrel=1
-pkgdesc='PGCA: An Algorithm to Link Protein Groups Created from MS/MS Data'
-arch=('any')
-url="https://bioconductor.org/packages/${_pkgname}"
-license=('GPL')
+pkgver=${_pkgver//-/.}
+pkgrel=2
+pkgdesc="An Algorithm to Link Protein Groups Created from MS/MS Data"
+arch=(any)
+url="https://bioconductor.org/packages/$_pkgname"
+license=('GPL-2.0-or-later')
depends=(
r
)
@@ -18,14 +18,15 @@ optdepends=(
r-testthat
)
source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
-sha256sums=('7a1892848a5577c238184419e719247504ce82180044ae9bf7109aa133cce06a')
+md5sums=('43c58c5b347ebf060a9e6afdc8aa8e93')
+b2sums=('a43e7b2f25a506f917960ab0d193f7399db2d82bd82f2e164b0eb8f9b80fc90252ab3750aaddffe31ef349252f011566f31fc6715930a272cdbe1f3b082b715a')
build() {
- R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+ mkdir build
+ R CMD INSTALL -l build "$_pkgname"
}
package() {
- install -dm0755 "${pkgdir}/usr/lib/R/library"
- cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+ install -d "$pkgdir/usr/lib/R/library"
+ cp -a --no-preserve=ownership "build/$_pkgname" "$pkgdir/usr/lib/R/library"
}
-# vim:set ts=2 sw=2 et: