summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorViktor Drobot2020-01-31 18:08:35 +0300
committerViktor Drobot2020-01-31 18:08:35 +0300
commit96f0208578a9a063bf4c1a748c816fd73c8c6162 (patch)
tree46d7d0fbbc300ca7dc8cfd8a27d27d13b956901f
parent8266d8a158f7e17e1028dc8fa133b60c951eec7f (diff)
downloadaur-96f0208578a9a063bf4c1a748c816fd73c8c6162.tar.gz
Fixed PKGBUILD
-rw-r--r--.SRCINFO22
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD34
3 files changed, 35 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 304c171d45f3..55027c396702 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,23 @@
pkgbase = r-pillar
pkgdesc = Coloured Formatting for Columns
- pkgver = 1.4.2
+ pkgver = 1.4.3
pkgrel = 1
- url = http://cran.r-project.org/web/packages/pillar/index.html
- arch = x86_64
+ url = https://cran.r-project.org/package=pillar
+ arch = any
license = GPL3
depends = r
depends = r-cli
- depends = r-crayon
+ depends = r-crayon>=1.3.4
depends = r-fansi
- depends = r-rlang
- depends = r-utf8
- depends = r-vctrs
- source = http://cran.r-project.org/src/contrib/pillar_1.4.2.tar.gz
- md5sums = 0685272b193615c8fcd56cd53cda3898
+ depends = r-rlang>=0.3.0
+ depends = r-utf8>=1.1.0
+ depends = r-vctrs>=0.2.0
+ optdepends = r-knitr
+ optdepends = r-lubridate
+ optdepends = r-testthat
+ optdepends = r-withr
+ source = https://cran.r-project.org/src/contrib/pillar_1.4.3.tar.gz
+ md5sums = 30f6de36b4ca7f3482aee7db456d7cdf
pkgname = r-pillar
diff --git a/.gitignore b/.gitignore
deleted file mode 100644
index 6ae0b18a1f6c..000000000000
--- a/.gitignore
+++ /dev/null
@@ -1,4 +0,0 @@
-/pkg
-/src
-*.tar.gz
-*.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
index 68947e65562c..915ad06a446d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,29 @@
+# Contributor: Viktor Drobot (aka dviktor) linux776 [at] gmail [dot] com
# Contributor: Grey Christoforo <first name at last name dot net>
-pkgname=r-pillar
-_cran_name=pillar
-pkgver=1.4.2
+
+_cranname=pillar
+_cranver=1.4.3
+pkgname=r-${_cranname,,}
+pkgver=${_cranver//[:-]/.}
pkgrel=1
pkgdesc="Coloured Formatting for Columns"
-arch=('x86_64')
-url="http://cran.r-project.org/web/packages/${_cran_name}/index.html"
-license=('GPL3')
-depends=('r' 'r-cli' 'r-crayon' 'r-fansi' 'r-rlang' 'r-utf8' 'r-vctrs')
-source=("http://cran.r-project.org/src/contrib/${_cran_name}_${pkgver}.tar.gz")
-md5sums=('0685272b193615c8fcd56cd53cda3898')
+arch=(any)
+url="https://cran.r-project.org/package=${_cranname}"
+license=(GPL3)
+depends=(r r-cli 'r-crayon>=1.3.4' r-fansi 'r-rlang>=0.3.0' 'r-utf8>=1.1.0' 'r-vctrs>=0.2.0')
+optdepends=(r-knitr r-lubridate r-testthat r-withr)
+source=("https://cran.r-project.org/src/contrib/${_cranname}_${_cranver}.tar.gz")
+md5sums=('30f6de36b4ca7f3482aee7db456d7cdf')
+
+build() {
+ cd "${srcdir}"
+
+ R CMD INSTALL ${_cranname}_${_cranver}.tar.gz -l ${srcdir}
+}
package() {
- mkdir -p $pkgdir/usr/lib/R/library
- cd $srcdir
+ cd "${srcdir}"
- R CMD INSTALL -l $pkgdir/usr/lib/R/library ./${_cran_name}
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_cranname}" "${pkgdir}/usr/lib/R/library"
}