summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGrey Christoforo2019-02-09 13:20:09 +0000
committerGrey Christoforo2019-02-09 13:20:09 +0000
commit9c3a973bae8cdde43ff8bb0dd19905ccd0e8f4c0 (patch)
tree1e05920b082de3b3683f23395ea98a50a8b8df6d
parentc6d4c2d3c078db542afc22065858c4500428ccf9 (diff)
downloadaur-9c3a973bae8cdde43ff8bb0dd19905ccd0e8f4c0.tar.gz
version bump
-rw-r--r--.SRCINFO9
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD27
3 files changed, 21 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ca1dfb3e5a76..4111b683888a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,8 @@
pkgbase = r-pillar
- pkgdesc = Format columns of data using the full range of colours in modern terminals.
- pkgver = 1.3.0
+ pkgdesc = Coloured Formatting for Columns
+ pkgver = 1.3.1
pkgrel = 1
url = http://cran.r-project.org/web/packages/pillar/index.html
- arch = i686
arch = x86_64
license = GPL3
depends = r
@@ -12,8 +11,8 @@ pkgbase = r-pillar
depends = r-fansi
depends = r-rlang
depends = r-utf8
- source = http://cran.r-project.org/src/contrib/pillar_1.3.0.tar.gz
- sha256sums = aed845ae4888be9a7340eed57536e3fe6cb46e89d905897fb9b0635797cfcae0
+ source = http://cran.r-project.org/src/contrib/pillar_1.3.1.tar.gz
+ md5sums = fe7ef47df16a5599b20121de28923c32
pkgname = r-pillar
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..6ae0b18a1f6c
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/pkg
+/src
+*.tar.gz
+*.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
index 63d3bda32fef..85a5963052c1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,19 @@
-# Maintainer: Clint Valentine <valentine.clint@gmail.com>
-
-_cranname=pillar
-_cranver=1.3.0
-pkgname="r-${_cranname}"
-pkgver="${_cranver}"
+# Contributor: Grey Christoforo <first name at last name dot net>
+pkgname=r-pillar
+_cran_name=pillar
+pkgver=1.3.1
pkgrel=1
-pkgdesc="Format columns of data using the full range of colours in modern terminals."
-url="http://cran.r-project.org/web/packages/${_cranname}/index.html"
-arch=('i686' 'x86_64')
+pkgdesc="Coloured Formatting for Columns"
+arch=('x86_64')
+url="http://cran.r-project.org/web/packages/${_cran_name}/index.html"
license=('GPL3')
depends=('r' 'r-cli' 'r-crayon' 'r-fansi' 'r-rlang' 'r-utf8')
-source=("http://cran.r-project.org/src/contrib/${_cranname}_${_cranver}.tar.gz")
-sha256sums=('aed845ae4888be9a7340eed57536e3fe6cb46e89d905897fb9b0635797cfcae0')
+source=("http://cran.r-project.org/src/contrib/${_cran_name}_${pkgver}.tar.gz")
+md5sums=('fe7ef47df16a5599b20121de28923c32')
package() {
- mkdir -p "${pkgdir}/usr/lib/R/library"
- cd "${srcdir}"
- R CMD INSTALL "${_cranname}" -l "${pkgdir}/usr/lib/R/library"
+ mkdir -p $pkgdir/usr/lib/R/library
+ cd $srcdir
+
+ R CMD INSTALL -l $pkgdir/usr/lib/R/library ./${_cran_name}
}