summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlex Branham2018-08-21 08:16:12 -0500
committerAlex Branham2018-08-21 08:16:12 -0500
commit27c8fd47f532e530a504e10d9071ead16e665f8e (patch)
treeb0df3c8ba17f9c6660b6cd15243eee4a700197be
parent163b0164fbac807689bf9c30a559a6888755c5a7 (diff)
downloadaur-27c8fd47f532e530a504e10d9071ead16e665f8e.tar.gz
Upkg 2.7.0
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD22
2 files changed, 14 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index af82f6f2e54c..249944e34f45 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,16 @@
pkgbase = r-pls
pkgdesc = Partial Least Squares and Principal Component Regression
- pkgver = 2.6.0
+ pkgver = 2.7.0
pkgrel = 1
url = https://cran.r-project.org/package=pls
arch = any
license = GPL2
depends = r
optdepends = r-rmpi
- source = https://cran.r-project.org/src/contrib/pls_2.6-0.tar.gz
- md5sums = 04e02e8e46d983c5ed53c1f952b329df
+ optdepends = r-testthat
+ optdepends = r-runit
+ source = https://cran.r-project.org/src/contrib/pls_2.7-0.tar.gz
+ md5sums = cee00eec5332707f55de26ddee595baa
pkgname = r-pls
diff --git a/PKGBUILD b/PKGBUILD
index 169cd8867ef0..47cdb028068c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,22 @@
# Maintainer: Alex Branham <branham@utexas.edu>
-_cranname=pls
-_cranver=2.6-0
-_pkgtar=${_cranname}_${_cranver}.tar.gz
+_cranver=2.7-0
pkgname=r-pls
pkgver=${_cranver//[:-]/.}
pkgrel=1
-pkgdesc="Partial Least Squares and Principal Component Regression"
+pkgdesc='Partial Least Squares and Principal Component Regression'
arch=('any')
-url="https://cran.r-project.org/package=${_cranname}"
+url='https://cran.r-project.org/package=pls'
license=('GPL2')
depends=('r' )
-
-optdepends=('r-rmpi')
-
-source=("https://cran.r-project.org/src/contrib/${_pkgtar}")
-md5sums=('04e02e8e46d983c5ed53c1f952b329df')
+optdepends=('r-rmpi' 'r-testthat' 'r-runit')
+source=("https://cran.r-project.org/src/contrib/pls_"$_cranver".tar.gz")
+md5sums=('cee00eec5332707f55de26ddee595baa')
build(){
- R CMD INSTALL ${_pkgtar} -l $srcdir
+ R CMD INSTALL pls_"$_cranver".tar.gz -l "$srcdir"
}
package() {
- install -d "$pkgdir/usr/lib/R/library"
- cp -r "$srcdir/$_cranname" "$pkgdir/usr/lib/R/library"
+ install -dm0755 "$pkgdir"/usr/lib/R/library
+ cp -a --no-preserve=ownership pls "$pkgdir"/usr/lib/R/library
}