summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatt Frichtl2018-05-30 20:35:43 -0400
committerMatt Frichtl2018-05-30 20:35:43 -0400
commitfcf22825d9c3f443b612ccaa08e8d1d4ee8d2aa4 (patch)
treec347b324eb56e5d5aead3994b768aee1436d6526
downloadaur-fcf22825d9c3f443b612ccaa08e8d1d4ee8d2aa4.tar.gz
Initial commit.
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD20
2 files changed, 35 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e50c1599e27b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = r-plyr
+ pkgdesc = Tools for Splitting, Applying and Combining Data
+ pkgver = 1.8.4
+ pkgrel = 1
+ url = http://cran.r-project.org/web/packages/plyr/index.html
+ arch = i686
+ arch = x86_64
+ license = MIT
+ depends = r>=3.1.0
+ depends = r-rcpp>=0.11.0
+ source = http://cran.r-project.org/src/contrib/plyr_1.8.4.tar.gz
+ md5sums = ef455cf7fc06e34837692156b7b2587b
+
+pkgname = r-plyr
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cd0b9641f74f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Originator: wagnerflo <florian@wagner-flo.net>
+# Maintainer: Matt Frichtl <frichtlm@gmail.com>
+_cranname=plyr
+_cranver=1.8.4
+pkgname=r-$_cranname
+pkgver=${_cranver}
+pkgrel=1
+pkgdesc="Tools for Splitting, Applying and Combining Data"
+url="http://cran.r-project.org/web/packages/${_cranname}/index.html"
+arch=('i686' 'x86_64')
+license=('MIT')
+depends=('r>=3.1.0' 'r-rcpp>=0.11.0')
+source=("http://cran.r-project.org/src/contrib/${_cranname}_${_cranver}.tar.gz")
+md5sums=('ef455cf7fc06e34837692156b7b2587b')
+
+package() {
+ mkdir -p ${pkgdir}/usr/lib/R/library
+ cd ${srcdir}
+ R CMD INSTALL ${_cranname} -l ${pkgdir}/usr/lib/R/library
+}