summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSukanka2022-06-06 18:52:22 +0800
committerSukanka2022-06-06 18:52:22 +0800
commit067603482a443b712cfa58459908658bc2d8b687 (patch)
tree4655746eb46645b048d32209c0954dd599693f2f
downloadaur-067603482a443b712cfa58459908658bc2d8b687.tar.gz
add r-pqsfinder
-rw-r--r--.SRCINFO30
-rw-r--r--PKGBUILD48
2 files changed, 78 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0dc5c2c9471c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,30 @@
+pkgbase = r-pqsfinder
+ pkgdesc = Identification of potential quadruplex forming sequences
+ pkgver = 2.12.0
+ pkgrel = 1
+ url = https://bioconductor.org/packages/pqsfinder
+ arch = x86_64
+ license = BSD
+ depends = r
+ depends = r-bh
+ depends = r-biostrings
+ depends = r-genomicranges
+ depends = r-iranges
+ depends = r-rcpp
+ depends = r-s4vectors
+ depends = make
+ depends = gcc
+ optdepends = r-biocstyle
+ optdepends = r-bsgenome.hsapiens.ucsc.hg38
+ optdepends = r-ggplot2
+ optdepends = r-gviz
+ optdepends = r-knitr
+ optdepends = r-rmarkdown
+ optdepends = r-rtracklayer
+ optdepends = r-stringi
+ optdepends = r-stringr
+ optdepends = r-testthat
+ source = https://bioconductor.org/packages/release/bioc/src/contrib/pqsfinder_2.12.0.tar.gz
+ sha256sums = 04d7523c5c597bed29ae66e23f03a11700a2564b035d3022a8a93cb58b0df4d7
+
+pkgname = r-pqsfinder
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fc6ea88162f5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,48 @@
+# system requirements: GNU make, C++11
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=pqsfinder
+_pkgver=2.12.0
+pkgname=r-${_pkgname,,}
+pkgver=2.12.0
+pkgrel=1
+pkgdesc='Identification of potential quadruplex forming sequences'
+arch=('x86_64')
+url="https://bioconductor.org/packages/${_pkgname}"
+license=('BSD')
+depends=(
+ r
+ r-bh
+ r-biostrings
+ r-genomicranges
+ r-iranges
+ r-rcpp
+ r-s4vectors
+ make
+ gcc
+)
+optdepends=(
+ r-biocstyle
+ r-bsgenome.hsapiens.ucsc.hg38
+ r-ggplot2
+ r-gviz
+ r-knitr
+ r-rmarkdown
+ r-rtracklayer
+ r-stringi
+ r-stringr
+ r-testthat
+)
+source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('04d7523c5c597bed29ae66e23f03a11700a2564b035d3022a8a93cb58b0df4d7')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+ install -Dm644 "${_pkgname}/LICENSE" -t "${pkgdir}/usr/share/licenses/${pkgname}"
+}
+# vim:set ts=2 sw=2 et: