summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorViktor Drobot2020-03-06 16:30:20 +0300
committerViktor Drobot2020-03-06 16:30:20 +0300
commitba3914aca8981aa0e6d5afefefe490ad97633273 (patch)
tree89b6fdb5e1d9d99ab271ce86c77fae197e31e602
parentd812b34125a470fe04c456c1b20fa20f4c48460c (diff)
downloadaur-ba3914aca8981aa0e6d5afefefe490ad97633273.tar.gz
Fixed PKGBUILD
-rw-r--r--PKGBUILD31
1 files changed, 17 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ab41156e9470..4cef06b251ca 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,31 @@
+# Maintainer: Viktor Drobot (aka dviktor) linux776 [at] gmail [dot] com
# Contributor: Kibouo <csonka.mihaly@hotmail.com>
# Contributor: Ward Segers <w@rdsegers.be>
# Contributor: Alex Branham <branham@utexas.edu>
+
_cranname=praise
_cranver=1.0.0
-_pkgtar=${_cranname}_${_cranver}.tar.gz
-pkgname=r-praise
+pkgname=r-${_cranname,,}
pkgver=${_cranver//[:-]/.}
pkgrel=1
pkgdesc="Praise Users"
-arch=('any')
+arch=(any)
url="https://cran.r-project.org/package=${_cranname}"
-license=('MIT')
-depends=('r' )
-
-optdepends=('r-testthat')
-
-source=("https://cran.r-project.org/src/contrib/${_pkgtar}")
+license=(MIT)
+depends=(r)
+optdepends=(r-testthat)
+source=("https://cran.r-project.org/src/contrib/${_cranname}_${_cranver}.tar.gz")
md5sums=('9318724cec0454884b5f762bee2da6a1')
-build(){
- R CMD INSTALL ${_pkgtar} -l $srcdir
+build() {
+ cd "${srcdir}"
+
+ R CMD INSTALL ${_cranname}_${_cranver}.tar.gz -l ${srcdir}
}
+
package() {
- install -d "$pkgdir/usr/lib/R/library"
- cp -r "$srcdir/$_cranname" "$pkgdir/usr/lib/R/library"
-}
+ cd "${srcdir}"
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_cranname}" "${pkgdir}/usr/lib/R/library"
+}