summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorViktor Drobot2020-03-06 16:21:12 +0300
committerViktor Drobot2020-03-06 16:21:12 +0300
commite6a195bd49fa418fc4f95d68168218bc47bcb9af (patch)
tree5e2af6f84948de99c270d2209951618e5203ab79
downloadaur-e6a195bd49fa418fc4f95d68168218bc47bcb9af.tar.gz
Initial release
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD28
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f48bec80d0d0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = r-prettyunits
+ pkgdesc = Pretty, Human Readable Formatting of Quantities
+ pkgver = 1.1.1
+ pkgrel = 1
+ url = https://cran.r-project.org/package=prettyunits
+ arch = any
+ license = MIT
+ depends = r
+ optdepends = r-codetools
+ optdepends = r-covr
+ optdepends = r-testthat
+ source = https://cran.r-project.org/src/contrib/prettyunits_1.1.1.tar.gz
+ md5sums = 0585a928696b8b7c259d2aaf8125762f
+
+pkgname = r-prettyunits
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..aa191e18df3e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Viktor Drobot (aka dviktor) linux776 [at] gmail [dot] com
+
+_cranname=prettyunits
+_cranver=1.1.1
+pkgname=r-${_cranname,,}
+pkgver=${_cranver//[:-]/.}
+pkgrel=1
+pkgdesc="Pretty, Human Readable Formatting of Quantities"
+arch=(any)
+url="https://cran.r-project.org/package=${_cranname}"
+license=(MIT)
+depends=(r)
+optdepends=(r-codetools r-covr r-testthat)
+source=("https://cran.r-project.org/src/contrib/${_cranname}_${_cranver}.tar.gz")
+md5sums=('0585a928696b8b7c259d2aaf8125762f')
+
+build() {
+ cd "${srcdir}"
+
+ R CMD INSTALL ${_cranname}_${_cranver}.tar.gz -l ${srcdir}
+}
+
+package() {
+ cd "${srcdir}"
+
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_cranname}" "${pkgdir}/usr/lib/R/library"
+}