summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSukanka2022-06-06 19:00:21 +0800
committerSukanka2022-06-06 19:00:21 +0800
commitb6024b2487f2056e502ac995ae572354d9584910 (patch)
tree0aca9932ac536c2597d2db683b518d9c68585b42
downloadaur-b6024b2487f2056e502ac995ae572354d9584910.tar.gz
add r-process
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD27
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1827872c03d1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = r-process
+ pkgdesc = Ciphergen SELDI-TOF Processing
+ pkgver = 1.72.0
+ pkgrel = 1
+ url = https://bioconductor.org/packages/PROcess
+ arch = any
+ license = Artistic2.0
+ depends = r
+ depends = r-icens
+ source = https://bioconductor.org/packages/release/bioc/src/contrib/PROcess_1.72.0.tar.gz
+ sha256sums = d092a53ce8e1d73596be1fc32b38a516e916fb1d39cf1a725978d7547feaf70e
+
+pkgname = r-process
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c74b3341e1b0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=PROcess
+_pkgver=1.72.0
+pkgname=r-${_pkgname,,}
+pkgver=1.72.0
+pkgrel=1
+pkgdesc='Ciphergen SELDI-TOF Processing'
+arch=('any')
+url="https://bioconductor.org/packages/${_pkgname}"
+license=('Artistic2.0')
+depends=(
+ r
+ r-icens
+)
+source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('d092a53ce8e1d73596be1fc32b38a516e916fb1d39cf1a725978d7547feaf70e')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+}
+# vim:set ts=2 sw=2 et: