summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlex Branham2018-05-30 09:28:24 -0500
committerAlex Branham2018-05-30 09:28:24 -0500
commitffaead8bf62870f742fb4864b04f8cbfa8612273 (patch)
treefb283c01faca99bdf5f94d986c0ae9e3d85d6540
downloadaur-ffaead8bf62870f742fb4864b04f8cbfa8612273.tar.gz
Initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD26
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ddd3df031708
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = r-processx
+ pkgdesc = Execute and Control System Processes
+ pkgver = 3.1.0
+ pkgrel = 1
+ url = https://cran.r-project.org/web/packages/processx/index.html
+ arch = any
+ license = MIT
+ depends = r
+ depends = r-assertthat
+ depends = r-crayon
+ depends = r-testthat
+ optdepends = r-covr
+ optdepends = r-debugme
+ optdepends = r-testthat
+ optdepends = r-withr
+ source = https://cran.r-project.org/src/contrib/processx_3.1.0.tar.gz
+ md5sums = 6eee8b45e34a79f9cef84d0d45926ca2
+
+pkgname = r-processx
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..83c2eff7155e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Alex Branham <branham@utexas.edu>
+_cranname=processx
+_cranver=3.1.0
+_pkgtar=${_cranname}_${_cranver}.tar.gz
+pkgname=r-processx
+pkgver=${_cranver//[:-]/.}
+pkgrel=1
+pkgdesc="Execute and Control System Processes"
+arch=('any')
+url="https://cran.r-project.org/web/packages/${_cranname}/index.html"
+license=('MIT')
+depends=('r' 'r-assertthat' 'r-crayon' 'r-testthat')
+
+optdepends=('r-covr' 'r-debugme' 'r-testthat' 'r-withr')
+
+source=("https://cran.r-project.org/src/contrib/${_pkgtar}")
+md5sums=('6eee8b45e34a79f9cef84d0d45926ca2')
+
+build(){
+ R CMD INSTALL ${_pkgtar} -l $srcdir
+}
+package() {
+ install -d "$pkgdir/usr/lib/R/library"
+ cp -r "$srcdir/$_cranname" "$pkgdir/usr/lib/R/library"
+}
+