summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSukanka2022-06-06 19:05:08 +0800
committerSukanka2022-06-06 19:05:08 +0800
commit37ac9747884aef5f9f3ad7c9290578081eeacf29 (patch)
treeb1eedbcf016113ccb193957ea36ae016e6c4ffc6
downloadaur-37ac9747884aef5f9f3ad7c9290578081eeacf29.tar.gz
add r-proloc
-rw-r--r--.SRCINFO58
-rw-r--r--PKGBUILD74
2 files changed, 132 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ce6e8a228554
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,58 @@
+pkgbase = r-proloc
+ pkgdesc = A unifying bioinformatics framework for spatial proteomics
+ pkgver = 1.36.0
+ pkgrel = 1
+ url = https://bioconductor.org/packages/pRoloc
+ arch = x86_64
+ license = GPL
+ depends = r
+ depends = r-biobase
+ depends = r-biocgenerics
+ depends = r-biocparallel
+ depends = r-biomart
+ depends = r-caret
+ depends = r-coda
+ depends = r-dendextend
+ depends = r-e1071
+ depends = r-fnn
+ depends = r-ggplot2
+ depends = r-gtools
+ depends = r-hexbin
+ depends = r-kernlab
+ depends = r-knitr
+ depends = r-laplacesdemon
+ depends = r-mclust
+ depends = r-mixtools
+ depends = r-mlinterfaces
+ depends = r-msnbase
+ depends = r-mvtnorm
+ depends = r-plyr
+ depends = r-proxy
+ depends = r-randomforest
+ depends = r-rcolorbrewer
+ depends = r-rcpp
+ depends = r-rcpparmadillo
+ depends = r-sampling
+ depends = r-scales
+ optdepends = r-akima
+ optdepends = r-annotationdbi
+ optdepends = r-biocstyle
+ optdepends = r-dplyr
+ optdepends = r-fields
+ optdepends = r-go.db
+ optdepends = r-hpar
+ optdepends = r-magick
+ optdepends = r-nipals
+ optdepends = r-prolocdata
+ optdepends = r-reshape
+ optdepends = r-rgl
+ optdepends = r-rmarkdown
+ optdepends = r-roxygen2
+ optdepends = r-rtsne
+ optdepends = r-testthat
+ optdepends = r-vegan
+ optdepends = r-xtable
+ source = https://bioconductor.org/packages/release/bioc/src/contrib/pRoloc_1.36.0.tar.gz
+ sha256sums = ffba6a8083ffd1153c6880f3e5f6522a96f5f1c578d29f68f9691bc059b7df86
+
+pkgname = r-proloc
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b1a9df406b36
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,74 @@
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=pRoloc
+_pkgver=1.36.0
+pkgname=r-${_pkgname,,}
+pkgver=1.36.0
+pkgrel=1
+pkgdesc='A unifying bioinformatics framework for spatial proteomics'
+arch=('x86_64')
+url="https://bioconductor.org/packages/${_pkgname}"
+license=('GPL')
+depends=(
+ r
+ r-biobase
+ r-biocgenerics
+ r-biocparallel
+ r-biomart
+ r-caret
+ r-coda
+ r-dendextend
+ r-e1071
+ r-fnn
+ r-ggplot2
+ r-gtools
+ r-hexbin
+ r-kernlab
+ r-knitr
+ r-laplacesdemon
+ r-mclust
+ r-mixtools
+ r-mlinterfaces
+ r-msnbase
+ r-mvtnorm
+ r-plyr
+ r-proxy
+ r-randomforest
+ r-rcolorbrewer
+ r-rcpp
+ r-rcpparmadillo
+ r-sampling
+ r-scales
+)
+optdepends=(
+ r-akima
+ r-annotationdbi
+ r-biocstyle
+ r-dplyr
+ r-fields
+ r-go.db
+ r-hpar
+ r-magick
+ r-nipals
+ r-prolocdata
+ r-reshape
+ r-rgl
+ r-rmarkdown
+ r-roxygen2
+ r-rtsne
+ r-testthat
+ r-vegan
+ r-xtable
+)
+source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('ffba6a8083ffd1153c6880f3e5f6522a96f5f1c578d29f68f9691bc059b7df86')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+}
+# vim:set ts=2 sw=2 et: