summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPekka Ristola2023-12-11 19:30:54 +0200
committerPekka Ristola2023-12-11 19:30:54 +0200
commitd0daa8375a174bca0d848155d54ad6e7fd944ba1 (patch)
treeb3919552b0d186570079d0da708cd08d36969ad5
downloadaur-d0daa8375a174bca0d848155d54ad6e7fd944ba1.tar.gz
Version 1.6.0
-rw-r--r--.SRCINFO54
-rw-r--r--PKGBUILD70
2 files changed, 124 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..910a6497f2fe
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,54 @@
+pkgbase = r-protgear
+ pkgdesc = Protein Micro Array Data Management and Interactive Visualization
+ pkgver = 1.6.0
+ pkgrel = 1
+ url = https://bioconductor.org/packages/protGear
+ arch = any
+ license = GPL3
+ depends = r-biobase
+ depends = r-data.table
+ depends = r-dplyr
+ depends = r-factoextra
+ depends = r-factominer
+ depends = r-flexdashboard
+ depends = r-genefilter
+ depends = r-ggally
+ depends = r-ggplot2
+ depends = r-ggpubr
+ depends = r-gtools
+ depends = r-htmltools
+ depends = r-kendall
+ depends = r-knitr
+ depends = r-limma
+ depends = r-magrittr
+ depends = r-pheatmap
+ depends = r-plotly
+ depends = r-plyr
+ depends = r-purrr
+ depends = r-readr
+ depends = r-remotes
+ depends = r-rlang
+ depends = r-rmarkdown
+ depends = r-shiny
+ depends = r-shinydashboard
+ depends = r-styler
+ depends = r-tibble
+ depends = r-tidyr
+ depends = r-vsn
+ optdepends = r-ggplotify
+ optdepends = r-gridextra
+ optdepends = r-magick
+ optdepends = r-png
+ optdepends = r-scales
+ optdepends = r-shinyalert
+ optdepends = r-shinycssloaders
+ optdepends = r-shinyfeedback
+ optdepends = r-shinyfiles
+ optdepends = r-shinyjs
+ optdepends = r-shinythemes
+ optdepends = r-shinywidgets
+ source = https://bioconductor.org/packages/release/bioc/src/contrib/protGear_1.6.0.tar.gz
+ md5sums = db63dca71894a3ebbf3b8b78512bccb4
+ sha256sums = bb5b47b1b5d12faba813f71e962a7e9fe80ae6807aa7dca8cceacbbec5681565
+
+pkgname = r-protgear
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9504a30c54b6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,70 @@
+# Maintainer: Pekka Ristola <pekkarr [at] protonmail [dot] com>
+
+_pkgname=protGear
+_pkgver=1.6.0
+pkgname=r-${_pkgname,,}
+pkgver=${_pkgver//-/.}
+pkgrel=1
+pkgdesc="Protein Micro Array Data Management and Interactive Visualization"
+arch=(any)
+url="https://bioconductor.org/packages/${_pkgname}"
+license=(GPL3)
+depends=(
+ r-biobase
+ r-data.table
+ r-dplyr
+ r-factoextra
+ r-factominer
+ r-flexdashboard
+ r-genefilter
+ r-ggally
+ r-ggplot2
+ r-ggpubr
+ r-gtools
+ r-htmltools
+ r-kendall
+ r-knitr
+ r-limma
+ r-magrittr
+ r-pheatmap
+ r-plotly
+ r-plyr
+ r-purrr
+ r-readr
+ r-remotes
+ r-rlang
+ r-rmarkdown
+ r-shiny
+ r-shinydashboard
+ r-styler
+ r-tibble
+ r-tidyr
+ r-vsn
+)
+optdepends=(
+ r-ggplotify
+ r-gridextra
+ r-magick
+ r-png
+ r-scales
+ r-shinyalert
+ r-shinycssloaders
+ r-shinyfeedback
+ r-shinyfiles
+ r-shinyjs
+ r-shinythemes
+ r-shinywidgets
+)
+source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+md5sums=('db63dca71894a3ebbf3b8b78512bccb4')
+sha256sums=('bb5b47b1b5d12faba813f71e962a7e9fe80ae6807aa7dca8cceacbbec5681565')
+
+build() {
+ mkdir -p build
+ R CMD INSTALL "$_pkgname" -l build
+}
+
+package() {
+ install -d "$pkgdir/usr/lib/R/library"
+ cp -a --no-preserve=ownership "build/$_pkgname" "$pkgdir/usr/lib/R/library"
+}