summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWard Segers2021-04-11 23:58:03 +0200
committerWard Segers2021-04-12 00:03:45 +0200
commit65c5a7470d194257b92aa2a85a89269f19dd84fb (patch)
tree6209a56caa403d426583a89ba3a8b206512576e8
downloadaur-65c5a7470d194257b92aa2a85a89269f19dd84fb.tar.gz
Initial release
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD24
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..382c43771029
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = r-proxy
+ pkgdesc = An extensible framework for auto- and cross-proximities
+ pkgver = 0.4.25
+ pkgrel = 1
+ url = https://cran.r-project.org/web/packages/proxy
+ arch = x86_64
+ license = GPL
+ depends = r
+ source = https://cran.r-project.org/src/contrib/proxy_0.4-25.tar.gz
+ sha512sums = c9bd65fb0901892b4bf405a301cc5ce9abcee0000afd1fbbb9bf310d3e9f0cc5a5a711b1c430f4c4c34c98e5b08be0405dc4545ec063f1655715eb365d49bce7
+
+pkgname = r-proxy
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ee8d268b7360
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Ward Segers <w@rdsegers.be>
+
+_cranver=0.4-25
+pkgname=r-proxy
+pkgver=${_cranver//[:-]/.}
+pkgrel=1
+pkgdesc='An extensible framework for auto- and cross-proximities'
+arch=('x86_64')
+url='https://cran.r-project.org/web/packages/proxy'
+license=('GPL')
+depends=('r')
+source=("https://cran.r-project.org/src/contrib/proxy_"$_cranver".tar.gz")
+sha512sums=('c9bd65fb0901892b4bf405a301cc5ce9abcee0000afd1fbbb9bf310d3e9f0cc5a5a711b1c430f4c4c34c98e5b08be0405dc4545ec063f1655715eb365d49bce7')
+
+build(){
+ R CMD INSTALL proxy_"$_cranver".tar.gz -l "$srcdir"
+}
+
+package() {
+ install -dm0755 "$pkgdir"/usr/lib/R/library
+ cp -a --no-preserve=ownership proxy "$pkgdir"/usr/lib/R/library
+}
+
+