summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorViktor Drobot2020-03-09 01:38:24 +0300
committerViktor Drobot2020-03-09 01:38:24 +0300
commit86188c0924c2055bf7459a2717d4b4ce73f6908a (patch)
treebd60354d2a7d22dfb89455f0a03c3988782b74f8
parent0ccdc685dcdb8945df26b085cffb7f3d87b27f2d (diff)
downloadaur-86188c0924c2055bf7459a2717d4b4ce73f6908a.tar.gz
Fixed PKGBUILD
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD35
2 files changed, 25 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6b0a74dec7d4..4c399dbec9a0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,12 @@
pkgbase = r-purrr
- pkgdesc = A complete and consistent functional programming toolkit for R.
+ pkgdesc = Functional Programming Tools
pkgver = 0.3.3
pkgrel = 1
url = https://cran.r-project.org/package=purrr
arch = i686
arch = x86_64
- license = GPL-3
+ license = gpl3
+ makedepends = gcc
depends = r>=3.2
depends = r-magrittr>=1.5
depends = r-rlang>=0.3.1
@@ -13,11 +14,11 @@ pkgbase = r-purrr
optdepends = r-crayon
optdepends = r-dplyr
optdepends = r-knitr
- optdepends = r-markdown
+ optdepends = r-rmarkdown
optdepends = r-testthat
optdepends = r-tibble
optdepends = r-tidyselect
- source = http://cran.r-project.org/src/contrib/purrr_0.3.3.tar.gz
+ source = https://cran.r-project.org/src/contrib/purrr_0.3.3.tar.gz
md5sums = c8eb681161e566440cae83b36d84704a
pkgname = r-purrr
diff --git a/PKGBUILD b/PKGBUILD
index 8f7b34492c08..0a6fbcc93ae0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,30 @@
-# Maintainer: frichtlm <frichtlm@gmail.com>
+# Maintainer: Viktor Drobot (aka dviktor) linux776 [at] gmail [dot] com
+# Contributor: frichtlm <frichtlm@gmail.com>
+
_cranname=purrr
_cranver=0.3.3
-pkgname=r-$_cranname
-pkgver=${_cranver}
+pkgname=r-${_cranname,,}
+pkgver=${_cranver//[:-]/.}
pkgrel=1
-pkgdesc="A complete and consistent functional programming toolkit for R."
-url="https://cran.r-project.org/package=purrr"
-arch=('i686' 'x86_64')
-license=('GPL-3')
+pkgdesc="Functional Programming Tools"
+arch=(i686 x86_64)
+url="https://cran.r-project.org/package=${_cranname}"
+license=(gpl3)
depends=('r>=3.2' 'r-magrittr>=1.5' 'r-rlang>=0.3.1')
-optdepends=('r-covr' 'r-crayon' 'r-dplyr' 'r-knitr' 'r-markdown' 'r-testthat' 'r-tibble' 'r-tidyselect')
-source=("http://cran.r-project.org/src/contrib/${_cranname}_${_cranver}.tar.gz")
-md5sums=('c8eb681161e566440cae83b36d84704a')
+makedepends=(gcc)
+optdepends=(r-covr r-crayon r-dplyr r-knitr r-rmarkdown r-testthat r-tibble r-tidyselect)
+source=("https://cran.r-project.org/src/contrib/${_cranname}_${_cranver}.tar.gz")
+md5sums=('c8eb681161e566440cae83b36d84704a')
build() {
- cd "${srcdir}"
- R CMD INSTALL ${_cranname}_${_cranver}.tar.gz -l $srcdir
+ cd "${srcdir}"
+
+ R CMD INSTALL ${_cranname}_${_cranver}.tar.gz -l ${srcdir}
}
package() {
- cd "${srcdir}"
- install -dm0755 "$pkgdir/usr/lib/R/library"
- cp -a --no-preserve=ownership "$_cranname" "$pkgdir/usr/lib/R/library"
+ cd "${srcdir}"
+
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_cranname}" "${pkgdir}/usr/lib/R/library"
}