summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSukanka2022-06-06 19:24:00 +0800
committerSukanka2022-06-06 19:24:00 +0800
commit5404b5cfe003561cde96d6684f91edb2ffaa1e9a (patch)
treed867801c0fbdb3e82028e1f7408b7f22235b33a8
downloadaur-5404b5cfe003561cde96d6684f91edb2ffaa1e9a.tar.gz
add r-qdnaseq
-rw-r--r--.SRCINFO31
-rw-r--r--PKGBUILD47
2 files changed, 78 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6df309fee2a9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,31 @@
+pkgbase = r-qdnaseq
+ pkgdesc = Quantitative DNA Sequencing for Chromosomal Aberrations
+ pkgver = 1.32.0
+ pkgrel = 1
+ url = https://bioconductor.org/packages/QDNAseq
+ arch = any
+ license = GPL
+ depends = r
+ depends = r-biobase
+ depends = r-cghbase
+ depends = r-cghcall
+ depends = r-dnacopy
+ depends = r-future.apply
+ depends = r-genomicranges
+ depends = r-iranges
+ depends = r-matrixstats
+ depends = r-r.utils
+ depends = r-rsamtools
+ optdepends = r-biocstyle
+ optdepends = r-bsgenome
+ optdepends = r-digest
+ optdepends = r-future
+ optdepends = r-genomeinfodb
+ optdepends = r-parallelly
+ optdepends = r-qdnaseq.hg19
+ optdepends = r-qdnaseq.mm10
+ optdepends = r-r.cache
+ source = https://bioconductor.org/packages/release/bioc/src/contrib/QDNAseq_1.32.0.tar.gz
+ sha256sums = 75bbde9b6cc55cd6a47b9f466358033a180b480def2144abdcc93a2a8e066668
+
+pkgname = r-qdnaseq
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5a5108fb4e16
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=QDNAseq
+_pkgver=1.32.0
+pkgname=r-${_pkgname,,}
+pkgver=1.32.0
+pkgrel=1
+pkgdesc='Quantitative DNA Sequencing for Chromosomal Aberrations'
+arch=('any')
+url="https://bioconductor.org/packages/${_pkgname}"
+license=('GPL')
+depends=(
+ r
+ r-biobase
+ r-cghbase
+ r-cghcall
+ r-dnacopy
+ r-future.apply
+ r-genomicranges
+ r-iranges
+ r-matrixstats
+ r-r.utils
+ r-rsamtools
+)
+optdepends=(
+ r-biocstyle
+ r-bsgenome
+ r-digest
+ r-future
+ r-genomeinfodb
+ r-parallelly
+ r-qdnaseq.hg19
+ r-qdnaseq.mm10
+ r-r.cache
+)
+source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('75bbde9b6cc55cd6a47b9f466358033a180b480def2144abdcc93a2a8e066668')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+}
+# vim:set ts=2 sw=2 et: