summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPekka Ristola2023-12-11 19:33:46 +0200
committerPekka Ristola2023-12-11 19:33:46 +0200
commit2366d97edeb956c5ca3615b0d1a55d9564af4ea0 (patch)
tree45a9f4c08c0676e490caba6412c2f11d820be8f5
downloadaur-2366d97edeb956c5ca3615b0d1a55d9564af4ea0.tar.gz
Version 1.6.0
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD48
2 files changed, 73 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b5c5160c5234
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = r-qsvar
+ pkgdesc = Generate Quality Surrogate Variable Analysis for Degradation Correction
+ pkgver = 1.6.0
+ pkgrel = 1
+ url = https://bioconductor.org/packages/qsvaR
+ arch = any
+ license = Artistic2.0
+ checkdepends = r-testthat
+ depends = r-ggplot2
+ depends = r-summarizedexperiment
+ depends = r-sva
+ optdepends = r-biocfilecache
+ optdepends = r-biocstyle
+ optdepends = r-covr
+ optdepends = r-knitr
+ optdepends = r-limma
+ optdepends = r-refmanager
+ optdepends = r-rmarkdown
+ optdepends = r-sessioninfo
+ optdepends = r-testthat
+ source = https://bioconductor.org/packages/release/bioc/src/contrib/qsvaR_1.6.0.tar.gz
+ md5sums = e9531cc164f93967a5d5d0469d47f7c7
+ sha256sums = 4cf3c4b26e421aed9f6c536fbe48cc21ea14d887311f3a4c46a58e38b94201d8
+
+pkgname = r-qsvar
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7fe520d9b097
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,48 @@
+# Maintainer: Pekka Ristola <pekkarr [at] protonmail [dot] com>
+
+_pkgname=qsvaR
+_pkgver=1.6.0
+pkgname=r-${_pkgname,,}
+pkgver=${_pkgver//-/.}
+pkgrel=1
+pkgdesc="Generate Quality Surrogate Variable Analysis for Degradation Correction"
+arch=(any)
+url="https://bioconductor.org/packages/${_pkgname}"
+license=(Artistic2.0)
+depends=(
+ r-ggplot2
+ r-summarizedexperiment
+ r-sva
+)
+checkdepends=(
+ r-testthat
+)
+optdepends=(
+ r-biocfilecache
+ r-biocstyle
+ r-covr
+ r-knitr
+ r-limma
+ r-refmanager
+ r-rmarkdown
+ r-sessioninfo
+ r-testthat
+)
+source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+md5sums=('e9531cc164f93967a5d5d0469d47f7c7')
+sha256sums=('4cf3c4b26e421aed9f6c536fbe48cc21ea14d887311f3a4c46a58e38b94201d8')
+
+build() {
+ mkdir -p build
+ R CMD INSTALL "$_pkgname" -l build
+}
+
+check() {
+ cd "$_pkgname/tests"
+ R_LIBS="$srcdir/build" NOT_CRAN=true Rscript --vanilla testthat.R
+}
+
+package() {
+ install -d "$pkgdir/usr/lib/R/library"
+ cp -a --no-preserve=ownership "build/$_pkgname" "$pkgdir/usr/lib/R/library"
+}