summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlex Branham2018-06-07 14:00:48 -0500
committerAlex Branham2018-06-07 14:00:48 -0500
commite66147c451bcaee4405c7560260f57c407a65363 (patch)
tree73673a18369c9edeb618f2804ccd0a10711958d3
downloadaur-e66147c451bcaee4405c7560260f57c407a65363.tar.gz
Initial commit
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD26
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bf6fc6d8f1a8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = r-quantmod
+ pkgdesc = Quantitative Financial Modelling Framework
+ pkgver = 0.4.13
+ pkgrel = 1
+ url = https://cran.r-project.org/package=quantmod
+ arch = any
+ license = GPL3
+ depends = r
+ depends = r-xts
+ depends = r-zoo
+ depends = r-curl
+ optdepends = r-dbi
+ optdepends = r-timeseries
+ optdepends = r-xml
+ optdepends = r-downloader
+ optdepends = r-jsonlite
+ source = https://cran.r-project.org/src/contrib/quantmod_0.4-13.tar.gz
+ md5sums = 3b9eb2762cc25a461bb981c238f92ef8
+
+pkgname = r-quantmod
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..874b25a57370
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Alex Branham <branham@utexas.edu>
+_cranname=quantmod
+_cranver=0.4-13
+_pkgtar=${_cranname}_${_cranver}.tar.gz
+pkgname=r-quantmod
+pkgver=${_cranver//[:-]/.}
+pkgrel=1
+pkgdesc="Quantitative Financial Modelling Framework"
+arch=('any')
+url="https://cran.r-project.org/package=${_cranname}"
+license=('GPL3')
+depends=('r' 'r-xts' 'r-zoo' 'r-curl')
+
+optdepends=('r-dbi' 'r-timeseries' 'r-xml' 'r-downloader' 'r-jsonlite')
+
+source=("https://cran.r-project.org/src/contrib/${_pkgtar}")
+md5sums=('3b9eb2762cc25a461bb981c238f92ef8')
+
+build(){
+ R CMD INSTALL ${_pkgtar} -l $srcdir
+}
+package() {
+ install -d "$pkgdir/usr/lib/R/library"
+ cp -r "$srcdir/$_cranname" "$pkgdir/usr/lib/R/library"
+}
+