summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSukanka2022-06-06 19:34:30 +0800
committerSukanka2022-06-06 19:34:30 +0800
commit548d81e618c4f22445dc4d405758dd753dc57a10 (patch)
tree21d65635a332b3cb4b37a7f4ac3e69d22b09c8a8
downloadaur-548d81e618c4f22445dc4d405758dd753dc57a10.tar.gz
add r-quantsmooth
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD27
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3cd129d6d45d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = r-quantsmooth
+ pkgdesc = Quantile smoothing and genomic visualization of array data
+ pkgver = 1.62.0
+ pkgrel = 1
+ url = https://bioconductor.org/packages/quantsmooth
+ arch = any
+ license = GPL
+ depends = r
+ depends = r-quantreg
+ source = https://bioconductor.org/packages/release/bioc/src/contrib/quantsmooth_1.62.0.tar.gz
+ sha256sums = 3a2bf8786a52c3709c2b5baf006f77365acd806cc2383005b24d471a43a8ea08
+
+pkgname = r-quantsmooth
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..86e2aea04cad
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=quantsmooth
+_pkgver=1.62.0
+pkgname=r-${_pkgname,,}
+pkgver=1.62.0
+pkgrel=1
+pkgdesc='Quantile smoothing and genomic visualization of array data'
+arch=('any')
+url="https://bioconductor.org/packages/${_pkgname}"
+license=('GPL')
+depends=(
+ r
+ r-quantreg
+)
+source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('3a2bf8786a52c3709c2b5baf006f77365acd806cc2383005b24d471a43a8ea08')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+}
+# vim:set ts=2 sw=2 et: