summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSukanka2022-06-06 19:34:54 +0800
committerSukanka2022-06-06 19:34:54 +0800
commitd56a6c6e74301d09085949990b1fbca079412b76 (patch)
tree922ad188f342021ade8ca3631d312bbf05f35d3c
downloadaur-d56a6c6e74301d09085949990b1fbca079412b76.tar.gz
add r-quartpac
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD35
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3c5b0cb14c54
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = r-quartpac
+ pkgdesc = Identification of mutational clusters in protein quaternary structures.
+ pkgver = 1.28.0
+ pkgrel = 1
+ url = https://bioconductor.org/packages/QuartPAC
+ arch = any
+ license = GPL
+ depends = r
+ depends = r-data.table
+ depends = r-graphpac
+ depends = r-ipac
+ depends = r-spacepac
+ optdepends = r-biocgenerics
+ optdepends = r-rgl
+ optdepends = r-runit
+ source = https://bioconductor.org/packages/release/bioc/src/contrib/QuartPAC_1.28.0.tar.gz
+ sha256sums = d0532016424683f5c28fc817674f2345e0fed0a44b65924c25cf4e93d0b4d6f5
+
+pkgname = r-quartpac
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..587956f36ec4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=QuartPAC
+_pkgver=1.28.0
+pkgname=r-${_pkgname,,}
+pkgver=1.28.0
+pkgrel=1
+pkgdesc='Identification of mutational clusters in protein quaternary structures.'
+arch=('any')
+url="https://bioconductor.org/packages/${_pkgname}"
+license=('GPL')
+depends=(
+ r
+ r-data.table
+ r-graphpac
+ r-ipac
+ r-spacepac
+)
+optdepends=(
+ r-biocgenerics
+ r-rgl
+ r-runit
+)
+source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('d0532016424683f5c28fc817674f2345e0fed0a44b65924c25cf4e93d0b4d6f5')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+}
+# vim:set ts=2 sw=2 et: