summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSukanka2022-06-06 19:38:53 +0800
committerSukanka2022-06-06 19:38:53 +0800
commitc474a5130a813ace33b404c747c4800b43b12eac (patch)
treef0ee3a5bf8ea85fe3312a6f7549ec356e3a706d4
downloadaur-c474a5130a813ace33b404c747c4800b43b12eac.tar.gz
add r-r3cpet
-rw-r--r--.SRCINFO36
-rw-r--r--PKGBUILD52
2 files changed, 88 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..32799f3feb12
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,36 @@
+pkgbase = r-r3cpet
+ pkgdesc = 3CPET: Finding Co-factor Complexes in Chia-PET experiment using a Hierarchical Dirichlet Process
+ pkgver = 1.28.0
+ pkgrel = 1
+ url = https://bioconductor.org/packages/R3CPET
+ arch = x86_64
+ license = GPL
+ depends = r
+ depends = r-biocgenerics
+ depends = r-clvalid
+ depends = r-data.table
+ depends = r-genomeinfodb
+ depends = r-genomicranges
+ depends = r-ggbio
+ depends = r-ggplot2
+ depends = r-hmisc
+ depends = r-igraph
+ depends = r-iranges
+ depends = r-pheatmap
+ depends = r-rcpp
+ depends = r-rcurl
+ depends = r-reshape2
+ depends = r-s4vectors
+ optdepends = r-annotationdbi
+ optdepends = r-biocstyle
+ optdepends = r-biomart
+ optdepends = r-biovizbase
+ optdepends = r-chippeakanno
+ optdepends = r-knitr
+ optdepends = r-org.hs.eg.db
+ optdepends = r-shiny
+ optdepends = r-txdb.hsapiens.ucsc.hg19.knowngene
+ source = https://bioconductor.org/packages/release/bioc/src/contrib/R3CPET_1.28.0.tar.gz
+ sha256sums = 35416dfe530f886d93241537621ecab8dd8317e2697fa1f57ff2b8cd515ffdc5
+
+pkgname = r-r3cpet
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c9c9d9688430
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,52 @@
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=R3CPET
+_pkgver=1.28.0
+pkgname=r-${_pkgname,,}
+pkgver=1.28.0
+pkgrel=1
+pkgdesc='3CPET: Finding Co-factor Complexes in Chia-PET experiment using a Hierarchical Dirichlet Process'
+arch=('x86_64')
+url="https://bioconductor.org/packages/${_pkgname}"
+license=('GPL')
+depends=(
+ r
+ r-biocgenerics
+ r-clvalid
+ r-data.table
+ r-genomeinfodb
+ r-genomicranges
+ r-ggbio
+ r-ggplot2
+ r-hmisc
+ r-igraph
+ r-iranges
+ r-pheatmap
+ r-rcpp
+ r-rcurl
+ r-reshape2
+ r-s4vectors
+)
+optdepends=(
+ r-annotationdbi
+ r-biocstyle
+ r-biomart
+ r-biovizbase
+ r-chippeakanno
+ r-knitr
+ r-org.hs.eg.db
+ r-shiny
+ r-txdb.hsapiens.ucsc.hg19.knowngene
+)
+source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('35416dfe530f886d93241537621ecab8dd8317e2697fa1f57ff2b8cd515ffdc5')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+}
+# vim:set ts=2 sw=2 et: