summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlex Branham2018-10-04 15:24:33 -0500
committerAlex Branham2018-10-04 15:24:33 -0500
commit126cc8b97e9a782493e664c290954c837f886ba6 (patch)
tree6d798e87a15df067ada6c3f6938d0ac438e9949d
parentce1b35b7073bc5bed24cb3b067819a3855984e18 (diff)
downloadaur-126cc8b97e9a782493e664c290954c837f886ba6.tar.gz
Upkg 2.3.0
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD22
2 files changed, 12 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 22c0f920983c..08e260a77864 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = r-r6
pkgdesc = Classes with Reference Semantics
- pkgver = 2.2.2
+ pkgver = 2.3.0
pkgrel = 1
url = https://cran.r-project.org/package=R6
arch = any
@@ -12,8 +12,8 @@ pkgbase = r-r6
optdepends = r-testthat
optdepends = r-ggplot2
optdepends = r-scales
- source = https://cran.r-project.org/src/contrib/R6_2.2.2.tar.gz
- md5sums = 635b58c65bff624a1fab69c6b1989801
+ source = https://cran.r-project.org/src/contrib/R6_2.3.0.tar.gz
+ md5sums = 92c91e7bc5c0309108ba9b0f54f9ed9b
pkgname = r-r6
diff --git a/PKGBUILD b/PKGBUILD
index 2f1b6847f5c0..53e577152b80 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,22 @@
-# Maintainer: Alex Branham <branham@utexas.edu>
-_cranname=R6
-_cranver=2.2.2
-_pkgtar=${_cranname}_${_cranver}.tar.gz
+# Maintainer: Alex Branham <alex.branham@gmail.com>
+_cranver=2.3.0
pkgname=r-r6
pkgver=${_cranver//[:-]/.}
pkgrel=1
-pkgdesc="Classes with Reference Semantics"
+pkgdesc='Classes with Reference Semantics'
arch=('any')
-url="https://cran.r-project.org/package=${_cranname}"
+url='https://cran.r-project.org/package=R6'
license=('MIT')
depends=('r' )
-
optdepends=('r-knitr' 'r-microbenchmark' 'r-pryr' 'r-testthat' 'r-ggplot2' 'r-scales')
-
-source=("https://cran.r-project.org/src/contrib/${_pkgtar}")
-md5sums=('635b58c65bff624a1fab69c6b1989801')
+source=("https://cran.r-project.org/src/contrib/R6_"$_cranver".tar.gz")
+md5sums=('92c91e7bc5c0309108ba9b0f54f9ed9b')
build(){
- R CMD INSTALL ${_pkgtar} -l $srcdir
+ R CMD INSTALL R6_"$_cranver".tar.gz -l "$srcdir"
}
package() {
- install -d "$pkgdir/usr/lib/R/library"
- cp -r "$srcdir/$_cranname" "$pkgdir/usr/lib/R/library"
+ install -dm0755 "$pkgdir"/usr/lib/R/library
+ cp -a --no-preserve=ownership R6 "$pkgdir"/usr/lib/R/library
}