summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSukanka2022-06-06 19:42:56 +0800
committerSukanka2022-06-06 19:42:56 +0800
commit711426ca459290e2fb8e66bfa392e56b23c4d96d (patch)
treed2b1215432f14e655ab046ba71e231a1771e38f4
downloadaur-711426ca459290e2fb8e66bfa392e56b23c4d96d.tar.gz
add r-rama
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD26
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..69e89e379fa6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = r-rama
+ pkgdesc = Robust Analysis of MicroArrays
+ pkgver = 1.70.0
+ pkgrel = 1
+ url = https://bioconductor.org/packages/rama
+ arch = x86_64
+ license = GPL
+ depends = r
+ source = https://bioconductor.org/packages/release/bioc/src/contrib/rama_1.70.0.tar.gz
+ sha256sums = 0ce6943e8efe2009f7e43d867c2cfe9889bec394c925f517e31a8f8604f620d0
+
+pkgname = r-rama
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d078663d6458
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=rama
+_pkgver=1.70.0
+pkgname=r-${_pkgname,,}
+pkgver=1.70.0
+pkgrel=1
+pkgdesc='Robust Analysis of MicroArrays'
+arch=('x86_64')
+url="https://bioconductor.org/packages/${_pkgname}"
+license=('GPL')
+depends=(
+ r
+)
+source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('0ce6943e8efe2009f7e43d867c2cfe9889bec394c925f517e31a8f8604f620d0')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+}
+# vim:set ts=2 sw=2 et: