summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSukanka2022-06-06 20:00:48 +0800
committerSukanka2022-06-06 20:00:48 +0800
commite2942006b2311cea0030cade2c2940708bd2ed7c (patch)
tree5c9aff7173dd74a4a33e0912b7d24de32ee646e1
downloadaur-e2942006b2311cea0030cade2c2940708bd2ed7c.tar.gz
add r-rcm
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD42
2 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..56994df4ad43
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = r-rcm
+ pkgdesc = Fit row-column association models with the negative binomial distribution for the microbiome
+ pkgver = 1.12.0
+ pkgrel = 1
+ url = https://bioconductor.org/packages/RCM
+ arch = any
+ license = GPL
+ depends = r
+ depends = r-alabama
+ depends = r-edger
+ depends = r-ggplot2
+ depends = r-nleqslv
+ depends = r-phyloseq
+ depends = r-rcolorbrewer
+ depends = r-reshape2
+ depends = r-tensor
+ depends = r-tseries
+ depends = r-vgam
+ depends = r-dbi
+ optdepends = r-knitr
+ optdepends = r-rmarkdown
+ optdepends = r-testthat
+ source = https://bioconductor.org/packages/release/bioc/src/contrib/RCM_1.12.0.tar.gz
+ sha256sums = fa749baf7eee3b7f783656424394f818e5bb2a49b146939cb2136c8a93d92d6c
+
+pkgname = r-rcm
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..09eff352ff52
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=RCM
+_pkgver=1.12.0
+pkgname=r-${_pkgname,,}
+pkgver=1.12.0
+pkgrel=1
+pkgdesc='Fit row-column association models with the negative binomial distribution for the microbiome'
+arch=('any')
+url="https://bioconductor.org/packages/${_pkgname}"
+license=('GPL')
+depends=(
+ r
+ r-alabama
+ r-edger
+ r-ggplot2
+ r-nleqslv
+ r-phyloseq
+ r-rcolorbrewer
+ r-reshape2
+ r-tensor
+ r-tseries
+ r-vgam
+ r-dbi
+)
+optdepends=(
+ r-knitr
+ r-rmarkdown
+ r-testthat
+)
+source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('fa749baf7eee3b7f783656424394f818e5bb2a49b146939cb2136c8a93d92d6c')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+}
+# vim:set ts=2 sw=2 et: