summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGrey Christoforo2019-02-09 15:50:34 +0000
committerGrey Christoforo2019-02-09 15:50:34 +0000
commit2ce8c3d2f614aa66294406766552f40b570814a5 (patch)
treec7beadbc849df9dbe20b2d9f01f04356173bac80
parentd93ad964138da8c7457bd20067a55efee577424a (diff)
downloadaur-2ce8c3d2f614aa66294406766552f40b570814a5.tar.gz
version bump
-rw-r--r--.SRCINFO10
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD33
3 files changed, 22 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 475a8eab761b..f13326cc53fa 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -2,12 +2,12 @@ pkgbase = r-rcolorbrewer
pkgdesc = ColorBrewer Palettes
pkgver = 1.1.2
pkgrel = 1
- url = https://cran.r-project.org/package=RColorBrewer
- arch = any
- license = Apache
+ url = http://cran.r-project.org/web/packages/RColorBrewer/index.html
+ arch = x86_64
+ license = GPL3
depends = r
- source = https://cran.r-project.org/src/contrib/RColorBrewer_1.1-2.tar.gz
- sha512sums = 29eeecae274c57f2af3366d072fb6a61a1e0be64aae9393e10c7e92c3b98473b60b7042b532c49e0ce2f53e6dce1a728ddd6937bbc64cedcb3664a429c3e54da
+ source = http://cran.r-project.org/src/contrib/RColorBrewer_1.1-2.tar.gz
+ md5sums = 66054d83eade4dff8a43ad4732691182
pkgname = r-rcolorbrewer
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..6ae0b18a1f6c
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/pkg
+/src
+*.tar.gz
+*.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
index a5017151c720..f6b52ceb42f9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,20 @@
-# Maintainer: Ward Segers <w@rdsegers.be>
-# Contributor: Alex Branham <branham@utexas.edu>
-
-_cranname=RColorBrewer
-_cranver=1.1-2
-_pkgtar=${_cranname}_${_cranver}.tar.gz
+# Contributor: Grey Christoforo <first name at last name dot net>
pkgname=r-rcolorbrewer
-pkgver=${_cranver//[:-]/.}
+_cran_name=RColorBrewer
+_pkgver=1.1-2
+pkgver=${_pkgver//-/.}
pkgrel=1
pkgdesc="ColorBrewer Palettes"
-arch=('any')
-url="https://cran.r-project.org/package=${_cranname}"
-license=('Apache')
+arch=('x86_64')
+url="http://cran.r-project.org/web/packages/${_cran_name}/index.html"
+license=('GPL3')
depends=('r')
-
-source=("https://cran.r-project.org/src/contrib/${_pkgtar}")
-sha512sums=('29eeecae274c57f2af3366d072fb6a61a1e0be64aae9393e10c7e92c3b98473b60b7042b532c49e0ce2f53e6dce1a728ddd6937bbc64cedcb3664a429c3e54da')
-
-build(){
- R CMD INSTALL ${_pkgtar} -l $srcdir
-}
+source=("http://cran.r-project.org/src/contrib/${_cran_name}_${_pkgver}.tar.gz")
+md5sums=('66054d83eade4dff8a43ad4732691182')
package() {
- install -d "$pkgdir/usr/lib/R/library"
- cp -r "$srcdir/$_cranname" "$pkgdir/usr/lib/R/library"
-}
+ mkdir -p $pkgdir/usr/lib/R/library
+ cd $srcdir
+ R CMD INSTALL -l $pkgdir/usr/lib/R/library ./${_cran_name}
+}