summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorViktor Drobot2020-01-31 18:18:47 +0300
committerViktor Drobot2020-01-31 18:18:47 +0300
commitf507fbca399b921e90bb6035433862373325ad61 (patch)
tree4c4211e57d6e95487b7616b354b5c75ae00a5af5
parent2ce8c3d2f614aa66294406766552f40b570814a5 (diff)
downloadaur-f507fbca399b921e90bb6035433862373325ad61.tar.gz
Fixed PKGBUILD
-rw-r--r--.SRCINFO10
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD32
3 files changed, 25 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f13326cc53fa..ca719c492a4b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -2,11 +2,11 @@ pkgbase = r-rcolorbrewer
pkgdesc = ColorBrewer Palettes
pkgver = 1.1.2
pkgrel = 1
- url = http://cran.r-project.org/web/packages/RColorBrewer/index.html
- arch = x86_64
- license = GPL3
- depends = r
- source = http://cran.r-project.org/src/contrib/RColorBrewer_1.1-2.tar.gz
+ url = https://cran.r-project.org/package=RColorBrewer
+ arch = any
+ license = Apache2.0
+ depends = r>=2.0.0
+ source = https://cran.r-project.org/src/contrib/RColorBrewer_1.1-2.tar.gz
md5sums = 66054d83eade4dff8a43ad4732691182
pkgname = r-rcolorbrewer
diff --git a/.gitignore b/.gitignore
deleted file mode 100644
index 6ae0b18a1f6c..000000000000
--- a/.gitignore
+++ /dev/null
@@ -1,4 +0,0 @@
-/pkg
-/src
-*.tar.gz
-*.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
index f6b52ceb42f9..2a7fc1687c68 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,28 @@
+# Contributor: Viktor Drobot (aka dviktor) linux776 [at] gmail [dot] com
# Contributor: Grey Christoforo <first name at last name dot net>
-pkgname=r-rcolorbrewer
-_cran_name=RColorBrewer
-_pkgver=1.1-2
-pkgver=${_pkgver//-/.}
+
+_cranname=RColorBrewer
+_cranver=1.1-2
+pkgname=r-${_cranname,,}
+pkgver=${_cranver//[:-]/.}
pkgrel=1
pkgdesc="ColorBrewer Palettes"
-arch=('x86_64')
-url="http://cran.r-project.org/web/packages/${_cran_name}/index.html"
-license=('GPL3')
-depends=('r')
-source=("http://cran.r-project.org/src/contrib/${_cran_name}_${_pkgver}.tar.gz")
+arch=(any)
+url="https://cran.r-project.org/package=${_cranname}"
+license=(Apache2.0)
+depends=('r>=2.0.0')
+source=("https://cran.r-project.org/src/contrib/${_cranname}_${_cranver}.tar.gz")
md5sums=('66054d83eade4dff8a43ad4732691182')
+build() {
+ cd "${srcdir}"
+
+ R CMD INSTALL ${_cranname}_${_cranver}.tar.gz -l ${srcdir}
+}
+
package() {
- mkdir -p $pkgdir/usr/lib/R/library
- cd $srcdir
+ cd "${srcdir}"
- R CMD INSTALL -l $pkgdir/usr/lib/R/library ./${_cran_name}
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_cranname}" "${pkgdir}/usr/lib/R/library"
}