summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatt Frichtl2018-05-30 20:57:58 -0400
committerMatt Frichtl2018-05-30 20:57:58 -0400
commit4ee30151525a5a7ad30815e0df123ec98fc5ac0c (patch)
tree3fb23bdea9dcac2e99b8a8472bffdbfba9e651a9
parent0d1af627fdf3ecefeede06e03c44c1dd547468c7 (diff)
downloadaur-4ee30151525a5a7ad30815e0df123ec98fc5ac0c.tar.gz
Updated to 0.12.17.
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD40
2 files changed, 24 insertions, 33 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d888cf164489..4a0c191a0d26 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,15 @@
pkgbase = r-rcpp
- pkgdesc = seamless r and c++ integration
- pkgver = 0.12.6
+ pkgdesc = Seamless R and C++ Integration
+ pkgver = 0.12.17
pkgrel = 1
- url = http://www.rcpp.org, http://dirk.eddelbuettel.com/code/rcpp.html, https://github.com/RcppCore/Rcpp
- arch = any
- license = GPL
- makedepends = curl
- makedepends = grep
- makedepends = python-html2text
+ url = http://cran.r-project.org/web/packages/Rcpp/index.html
+ arch = i686
+ arch = x86_64
+ license = GPL-2
+ license = GPL-3
depends = r>=3.0.0
+ source = http://cran.r-project.org/src/contrib/Rcpp_0.12.17.tar.gz
+ md5sums = eee1ece3b0a246c4a21e2e1e23213a8a
pkgname = r-rcpp
diff --git a/PKGBUILD b/PKGBUILD
index 94a62a1e4cf7..febdce7906d0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,19 @@
-# Maintainer: generated by script at https://github.com/zasdfgbnm/aurcran
-
-_pkgname=Rcpp
-_pkgnamelower=rcpp
-_repo='http://cran.stat.ucla.edu/'
-_cran="https://cran.r-project.org/web/packages/$_pkgname/index.html"
-pkgname=r-$_pkgnamelower
-pkgver=0.12.6
+# Maintainer: Matt Frichtl <frichtlm@gmail.com>
+_cranname=Rcpp
+_cranver=0.12.17
+pkgname=r-rcpp
+pkgver=${_cranver}
pkgrel=1
-pkgdesc='seamless r and c++ integration'
-arch=(any)
-url="http://www.rcpp.org, http://dirk.eddelbuettel.com/code/rcpp.html,
-https://github.com/RcppCore/Rcpp"
-license=('GPL')
+pkgdesc="Seamless R and C++ Integration"
+url="http://cran.r-project.org/web/packages/${_cranname}/index.html"
+arch=('i686' 'x86_64')
+license=('GPL-2' 'GPL-3')
depends=('r>=3.0.0')
-makedepends=('curl' 'grep' 'python-html2text')
-
-pkgver() {
- curl "$_cran" 2>/dev/null|html2text|grep -oP '(?<=Version:).*'|tr '-' '.'|grep -o '[0-9\.]*'
-}
-
-build() {
- Rscript -e "install.packages(\"$_pkgname\", lib=\"$srcdir\", repos=\"$_repo\")"
-}
+source=("http://cran.r-project.org/src/contrib/${_cranname}_${_cranver}.tar.gz")
+md5sums=('eee1ece3b0a246c4a21e2e1e23213a8a')
package() {
- install -d "$pkgdir/usr/lib/R/library"
- cp -r "$srcdir/$_pkgname" "$pkgdir/usr/lib/R/library"
-} \ No newline at end of file
+ mkdir -p ${pkgdir}/usr/lib/R/library
+ cd ${srcdir}
+ R CMD INSTALL ${_cranname} -l ${pkgdir}/usr/lib/R/library
+}