summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBioArchLinuxBot2024-01-09 18:07:39 +0000
committerBioArchLinuxBot2024-01-09 18:07:39 +0000
commit661dd86d8bd0a4fae5ccd3f3fd9343bf5f346c87 (patch)
tree01316a9f93ca13b6d56f2a1f2fb567b1b3b41f1f
parente5470c600a73f03adc466941f4236eb569547250 (diff)
downloadaur-661dd86d8bd0a4fae5ccd3f3fd9343bf5f346c87.tar.gz
[lilac] updated to 1.0.12-1
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD21
-rw-r--r--fix-version.patch13
3 files changed, 32 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 89e130fbbf28..bbd0b1bf4d7c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = r-rcpp
pkgdesc = Seamless R and C++ Integration
- pkgver = 1.0.11
+ pkgver = 1.0.12
pkgrel = 1
url = https://cran.r-project.org/package=Rcpp
arch = x86_64
@@ -11,8 +11,11 @@ pkgbase = r-rcpp
optdepends = r-pkgkitten
optdepends = r-rbenchmark
optdepends = r-tinytest
- source = https://cran.r-project.org/src/contrib/Rcpp_1.0.11.tar.gz
- md5sums = 5b9b45cde810d8b9762dd58c5d80da3a
- sha256sums = df757c3068599c6c05367900bcad93547ba3422d59802dbaca20fd74d4d2fa5f
+ source = https://cran.r-project.org/src/contrib/Rcpp_1.0.12.tar.gz
+ source = fix-version.patch
+ md5sums = 85d8f0c330b934bc8f498be40185a315
+ md5sums = 50440aea988c07da6fbcfc6ad945679e
+ b2sums = 511f3071d81531cdbb6de9b633e1406bb865a462587ea1e0e36c9d760cd9ea80a4ae67b44f2e2b7b5861fde727c0324bf9c3ea2b3cb9085f829fb1cb8dcd88c5
+ b2sums = a11024a357cfda063cd3599290ba58f749b8107d888407ec333f1cd2558ba6cdd07a24e7d61aff74d176e31b9470b475e5e86c682b71637e2bea9776b714835d
pkgname = r-rcpp
diff --git a/PKGBUILD b/PKGBUILD
index b68758059e5e..688dea119846 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,13 +4,13 @@
# Contributor: Matt Frichtl <frichtlm@gmail.com>
_pkgname=Rcpp
-_pkgver=1.0.11
+_pkgver=1.0.12
pkgname=r-${_pkgname,,}
pkgver=${_pkgver//-/.}
pkgrel=1
pkgdesc="Seamless R and C++ Integration"
arch=(x86_64)
-url="https://cran.r-project.org/package=${_pkgname}"
+url="https://cran.r-project.org/package=$_pkgname"
license=(GPL)
depends=(
r
@@ -24,18 +24,21 @@ optdepends=(
r-rbenchmark
r-tinytest
)
-source=("https://cran.r-project.org/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
-md5sums=('5b9b45cde810d8b9762dd58c5d80da3a')
-sha256sums=('df757c3068599c6c05367900bcad93547ba3422d59802dbaca20fd74d4d2fa5f')
+source=("https://cran.r-project.org/src/contrib/${_pkgname}_${_pkgver}.tar.gz"
+ "fix-version.patch")
+md5sums=('85d8f0c330b934bc8f498be40185a315'
+ '50440aea988c07da6fbcfc6ad945679e')
+b2sums=('511f3071d81531cdbb6de9b633e1406bb865a462587ea1e0e36c9d760cd9ea80a4ae67b44f2e2b7b5861fde727c0324bf9c3ea2b3cb9085f829fb1cb8dcd88c5'
+ 'a11024a357cfda063cd3599290ba58f749b8107d888407ec333f1cd2558ba6cdd07a24e7d61aff74d176e31b9470b475e5e86c682b71637e2bea9776b714835d')
prepare() {
- # upstream issue https://github.com/RcppCore/Rcpp/issues/1251
- sed -i 's/-447.1974945/-447.197893678525/' "$_pkgname/inst/tinytest/test_stats.R"
+ # fix version definition https://github.com/RcppCore/Rcpp/issues/1294
+ patch -Np1 -i fix-version.patch
}
build() {
- mkdir -p build
- R CMD INSTALL "$_pkgname" -l build
+ mkdir build
+ R CMD INSTALL -l build "$_pkgname"
}
check() {
diff --git a/fix-version.patch b/fix-version.patch
new file mode 100644
index 000000000000..b6f9002ac1d4
--- /dev/null
+++ b/fix-version.patch
@@ -0,0 +1,13 @@
+diff --git a/Rcpp/inst/include/Rcpp/config.h b/Rcpp/inst/include/Rcpp/config.h
+index fa75d9d..804089c 100644
+--- a/Rcpp/inst/include/Rcpp/config.h
++++ b/Rcpp/inst/include/Rcpp/config.h
+@@ -26,7 +26,7 @@
+ #define RcppDevVersion(maj, min, rev, dev) (((maj)*1000000) + ((min)*10000) + ((rev)*100) + (dev))
+
+ // the currently released version
+-#define RCPP_VERSION Rcpp_Version(1,0,11)
++#define RCPP_VERSION Rcpp_Version(1,0,12)
+ #define RCPP_VERSION_STRING "1.0.12"
+
+ // the current source snapshot (using four components, if a fifth is used in DESCRIPTION we ignore it)