summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPekka Ristola2022-04-03 14:29:46 +0300
committerPekka Ristola2022-04-03 14:29:46 +0300
commit9d5a596b6b1e838a03df9574382f1b54adaa17bf (patch)
tree355e4217053a6ec6e94137c59daf4bca5f95f930
parent3ea3b1e0bb7c66583a968a2211ab41b53f09e244 (diff)
downloadaur-9d5a596b6b1e838a03df9574382f1b54adaa17bf.tar.gz
Update to 1.0.8.3
-rw-r--r--.SRCINFO10
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD25
3 files changed, 28 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ae02fc0ba293..d503666ee99f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,18 @@
pkgbase = r-rcpp
pkgdesc = Seamless R and C++ Integration
- pkgver = 1.0.8
+ pkgver = 1.0.8.3
pkgrel = 1
url = https://cran.r-project.org/package=Rcpp
arch = i686
arch = x86_64
- license = GPL2
- license = GPL3
+ license = GPL
+ checkdepends = r-tinytest
depends = r
optdepends = r-tinytest
optdepends = r-inline
optdepends = r-rbenchmark
optdepends = r-pkgkitten
- source = https://cran.r-project.org/src/contrib/Rcpp_1.0.8.tar.gz
- sha256sums = 879f9296bc045ac4ed464578723bd37fcabbbdaa30aaaf070cf953e329f678ee
+ source = https://cran.r-project.org/src/contrib/Rcpp_1.0.8.3.tar.gz
+ sha256sums = 9da5b84cdaf56e972b41e669d496b1ece2e91bcd435505c68b9f2bd98375f8bf
pkgname = r-rcpp
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..018a3de08144
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!PKGBUILD
+!.SRCINFO
+!.gitignore
diff --git a/PKGBUILD b/PKGBUILD
index a032f3fe59c2..fc3223c2f652 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,39 @@
+# Maintainer: Pekka Ristola <pekkarr [at] protonmail [dot] com>
# Contributor: Viktor Drobot (aka dviktor) linux776 [at] gmail [dot] com
# Contributor: Matt Frichtl <frichtlm@gmail.com>
_cranname=Rcpp
-_cranver=1.0.8
+_cranver=1.0.8.3
pkgname=r-${_cranname,,}
pkgver=${_cranver//[:-]/.}
pkgrel=1
pkgdesc="Seamless R and C++ Integration"
arch=(i686 x86_64)
url="https://cran.r-project.org/package=${_cranname}"
-license=(GPL2 GPL3)
+license=(GPL)
depends=(r)
-optdepends=(r-tinytest r-inline r-rbenchmark r-pkgkitten)
+checkdepends=(r-tinytest)
+optdepends=(
+ r-tinytest
+ r-inline
+ r-rbenchmark
+ r-pkgkitten
+)
source=("https://cran.r-project.org/src/contrib/${_cranname}_${_cranver}.tar.gz")
-sha256sums=('879f9296bc045ac4ed464578723bd37fcabbbdaa30aaaf070cf953e329f678ee')
+sha256sums=('9da5b84cdaf56e972b41e669d496b1ece2e91bcd435505c68b9f2bd98375f8bf')
build() {
- R CMD INSTALL ${_cranname}_${_cranver}.tar.gz -l "${srcdir}"
+ mkdir -p build
+ R CMD INSTALL "${_cranname}" -l "${srcdir}/build"
+}
+
+check() {
+ cd "${_cranname}/tests"
+ R_LIBS="${srcdir}/build" RunAllRcppTests=yes Rscript --vanilla tinytest.R
}
package() {
install -dm0755 "${pkgdir}/usr/lib/R/library"
- cp -a --no-preserve=ownership "${_cranname}" "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "build/${_cranname}" "${pkgdir}/usr/lib/R/library"
}