summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlex Branham2018-05-27 16:21:01 -0500
committerAlex Branham2018-05-27 16:21:01 -0500
commit3a38fddc7b0b3b6a5f34f3108d1f5425fcaea298 (patch)
tree06b9692ed0e28d229a3337c972eea5d43464f684
downloadaur-3a38fddc7b0b3b6a5f34f3108d1f5425fcaea298.tar.gz
Initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD20
2 files changed, 34 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c312e78fa9c3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = r-rcppeigen
+pkgdesc = R and 'Eigen' integration using 'Rcpp'.
+pkgver = 0.3.3.4.0
+pkgrel = 1
+url = https://cran.r-project.org/web/packages/RcppEigen/index.html
+arch = x86_64
+license = GPL
+depends = r
+depends = r-cran-cpp
+source = https://cran.r-project.org/src/contrib/RcppEigen_0.3.3.4.0.tar.gz
+md5sums = 78ee1ef7c6043efa875434ae5fcea2ec
+
+pkgname = r-rcppeigen
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3b17a8ede213
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Alex Branham <branham@utexas.edu>
+_cranname=RcppEigen
+_cranver=0.3.3.4.0
+pkgname=r-rcppeigen
+pkgver=${_cranver//[:-]/.}
+pkgrel=1
+pkgdesc="R and 'Eigen' integration using 'Rcpp'. "
+url="https://cran.r-project.org/web/packages/${_cranname}/index.html"
+arch=('x86_64')
+license=('GPL')
+depends=('r'
+ 'r-cran-cpp')
+# optdepends=('r-inline' 'r-pkgkitten')
+source=("https://cran.r-project.org/src/contrib/${_cranname}_${_cranver}.tar.gz")
+md5sums=('78ee1ef7c6043efa875434ae5fcea2ec')
+package() {
+ mkdir -p ${pkgdir}/usr/lib/R/library
+ cd "${srcdir}"
+ R CMD INSTALL ${_cranname} -l ${pkgdir}/usr/lib/R/library
+}