summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGrey Christoforo2019-02-09 15:09:01 +0000
committerGrey Christoforo2019-02-09 15:09:01 +0000
commit3beb824fb60633aa7e6c93f03d13753bfa8af76a (patch)
treeaa222375e8f8481f15b0759583d579ec093878c3
downloadaur-3beb824fb60633aa7e6c93f03d13753bfa8af76a.tar.gz
initial commit
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD19
3 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..89a48ae22e48
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = r-rcppparallel
+ pkgdesc = Parallel Programming Tools for 'Rcpp'
+ pkgver = 4.4.2
+ pkgrel = 1
+ url = http://cran.r-project.org/web/packages/RcppParallel/index.html
+ arch = x86_64
+ license = GPL3
+ depends = r
+ source = http://cran.r-project.org/src/contrib/RcppParallel_4.4.2.tar.gz
+ md5sums = 7b327a8497cde8df49e85745fe66e5f8
+
+pkgname = r-rcppparallel
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..6ae0b18a1f6c
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/pkg
+/src
+*.tar.gz
+*.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..39f7753c38f3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Contributor: Grey Christoforo <first name at last name dot net>
+pkgname=r-rcppparallel
+_cran_name=RcppParallel
+pkgver=4.4.2
+pkgrel=1
+pkgdesc="Parallel Programming Tools for 'Rcpp'"
+arch=('x86_64')
+url="http://cran.r-project.org/web/packages/${_cran_name}/index.html"
+license=('GPL3')
+depends=('r')
+source=("http://cran.r-project.org/src/contrib/${_cran_name}_${pkgver}.tar.gz")
+md5sums=('7b327a8497cde8df49e85745fe66e5f8')
+
+package() {
+ mkdir -p $pkgdir/usr/lib/R/library
+ cd $srcdir
+
+ R CMD INSTALL -l $pkgdir/usr/lib/R/library ./${_cran_name}
+}