summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsukanka2022-07-21 23:03:14 +0800
committersukanka2022-07-21 23:03:14 +0800
commitf2b2d6b83fcd92d40eccb268e4c989b21a49a5e2 (patch)
tree0b43f4d51faa6d20c83db3085a12ad426cacfe57
parent922868b6f04cbb1e936e3b319475ffe4e90c2c65 (diff)
downloadaur-f2b2d6b83fcd92d40eccb268e4c989b21a49a5e2.tar.gz
takeover package
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD46
2 files changed, 31 insertions, 32 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ca4e289075b8..3d0b3404ab2f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,14 @@
pkgbase = r-rcpptoml
- pkgdesc = The configuration format defined by 'TOML' (which expands to "Tom's Obvious Markup Language") specifies an excellent format (described at <https://toml.io/en/>) suitable for both human editing as well as the common uses of a machine-readable format
+ pkgdesc = 'Rcpp' Bindings to Parser for Tom's Obvious Markup Language
pkgver = 0.1.7
- pkgrel = 1
+ pkgrel = 3
url = https://cran.r-project.org/package=RcppTOML
- arch = any
- license = GPL2
- license = GPL3
- checkdepends = r-tinytest
- depends = r>=3.3.0
- depends = r-rcpp>=0.11.5
+ arch = x86_64
+ license = GPL
+ depends = r
+ depends = r-rcpp
+ optdepends = r-tinytest
source = https://cran.r-project.org/src/contrib/RcppTOML_0.1.7.tar.gz
- sha512sums = c1a9e2a0f0c0229620125b6b18e5fb73fcb059d916c716f2cb7cc0bfbdb6253e71462a3fe7482e5d2f0672d429a81307effc89c26f79f5a99fe393c6a9d35ce9
+ sha256sums = 2f09f00cbee6c6eeff5d5f0195c10de0155496de15fbe8189c18627ee3090541
pkgname = r-rcpptoml
diff --git a/PKGBUILD b/PKGBUILD
index 1fee932562c1..904c57bf3675 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,31 @@
-# Maintainer: Robert Greener <me@r0bert.dev>
+# system requirements: A C++11 compiler; g++ (>= 4.9.*) or newer works.
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
-_cranname=RcppTOML
-_cranver=0.1.7
-pkgname=r-${_cranname,,}
-pkgver=${_cranver//[:-]/.}
-pkgrel=1
-pkgdesc="The configuration format defined by 'TOML' (which expands to \"Tom's Obvious Markup Language\") specifies an excellent format (described at <https://toml.io/en/>) suitable for both human editing as well as the common uses of a machine-readable format"
-arch=(any)
-url="https://cran.r-project.org/package=${_cranname}"
-license=(GPL2 GPL3)
-depends=('r>=3.3.0' 'r-rcpp>=0.11.5')
-checkdepends=(r-tinytest)
-source=("https://cran.r-project.org/src/contrib/${_cranname}_${_cranver}.tar.gz")
-sha512sums=("c1a9e2a0f0c0229620125b6b18e5fb73fcb059d916c716f2cb7cc0bfbdb6253e71462a3fe7482e5d2f0672d429a81307effc89c26f79f5a99fe393c6a9d35ce9")
+_pkgname=RcppTOML
+_pkgver=0.1.7
+pkgname=r-${_pkgname,,}
+pkgver=0.1.7
+pkgrel=3
+pkgdesc="'Rcpp' Bindings to Parser for Tom's Obvious Markup Language"
+arch=('x86_64')
+url="https://cran.r-project.org/package=${_pkgname}"
+license=('GPL')
+depends=(
+ r
+ r-rcpp
+)
+optdepends=(
+ r-tinytest
+)
+source=("https://cran.r-project.org/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('2f09f00cbee6c6eeff5d5f0195c10de0155496de15fbe8189c18627ee3090541')
build() {
- mkdir -p build
- R CMD INSTALL ${_cranname}_${_cranver}.tar.gz -l "${srcdir}/build"
-}
-
-check() {
- cd "${_cranname}/tests"
- R_LIBS="${srcdir}/build" NOT_CRAN=true Rscript --vanilla tinytest.R
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
}
package() {
install -dm0755 "${pkgdir}/usr/lib/R/library"
-
- cp -a --no-preserve=ownership "build/${_cranname}" "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
}
+# vim:set ts=2 sw=2 et: