summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGrey Christoforo2019-02-09 14:13:17 +0000
committerGrey Christoforo2019-02-09 14:13:17 +0000
commitd2a1cef8d11f00a1763eb2cd84d2121b749c64f4 (patch)
treee9a62f22fea37ddedff35b8e6e6257cd3e5814b3
downloadaur-d2a1cef8d11f00a1763eb2cd84d2121b749c64f4.tar.gz
initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD20
3 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8803095cb79c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = r-rcurl
+ pkgdesc = General Network (HTTP/FTP/...) Client Interface for R
+ pkgver = 1.95.4.11
+ pkgrel = 1
+ url = http://cran.r-project.org/web/packages/RCurl/index.html
+ arch = x86_64
+ license = GPL3
+ depends = r
+ depends = r-bitops
+ source = http://cran.r-project.org/src/contrib/RCurl_1.95-4.11.tar.gz
+ md5sums = 6218087742f61ab2dfbbe4b18ac248a0
+
+pkgname = r-rcurl
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..6ae0b18a1f6c
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/pkg
+/src
+*.tar.gz
+*.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4835818d0a52
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Contributor: Grey Christoforo <first name at last name dot net>
+pkgname=r-rcurl
+_cran_name=RCurl
+_pkgver=1.95-4.11
+pkgver=${_pkgver//-/.}
+pkgrel=1
+pkgdesc="General Network (HTTP/FTP/...) Client Interface for R"
+arch=('x86_64')
+url="http://cran.r-project.org/web/packages/${_cran_name}/index.html"
+license=('GPL3')
+depends=('r' 'r-bitops')
+source=("http://cran.r-project.org/src/contrib/${_cran_name}_${_pkgver}.tar.gz")
+md5sums=('6218087742f61ab2dfbbe4b18ac248a0')
+
+package() {
+ mkdir -p $pkgdir/usr/lib/R/library
+ cd $srcdir
+
+ R CMD INSTALL -l $pkgdir/usr/lib/R/library ./${_cran_name}
+}