summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSukanka2022-06-06 20:20:20 +0800
committerSukanka2022-06-06 20:20:20 +0800
commitffa2ec5a58b923073ceadc2da673b8808b20998b (patch)
tree4b1f09952a3877c58922945d3df0c15fd43968e3
downloadaur-ffa2ec5a58b923073ceadc2da673b8808b20998b.tar.gz
add r-reconsi
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD36
2 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f392ccb076e4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = r-reconsi
+ pkgdesc = Resampling Collapsed Null Distributions for Simultaneous Inference
+ pkgver = 1.8.0
+ pkgrel = 1
+ url = https://bioconductor.org/packages/reconsi
+ arch = any
+ license = GPL
+ depends = r
+ depends = r-ggplot2
+ depends = r-matrixstats
+ depends = r-phyloseq
+ depends = r-reshape2
+ depends = r-ks
+ optdepends = r-knitr
+ optdepends = r-rmarkdown
+ optdepends = r-testthat
+ source = https://bioconductor.org/packages/release/bioc/src/contrib/reconsi_1.8.0.tar.gz
+ sha256sums = 583f058346dcf11a019e5067306427e3aac0377eafd5afba7ada72be924afd6e
+
+pkgname = r-reconsi
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..30d7c3329e3d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=reconsi
+_pkgver=1.8.0
+pkgname=r-${_pkgname,,}
+pkgver=1.8.0
+pkgrel=1
+pkgdesc='Resampling Collapsed Null Distributions for Simultaneous Inference'
+arch=('any')
+url="https://bioconductor.org/packages/${_pkgname}"
+license=('GPL')
+depends=(
+ r
+ r-ggplot2
+ r-matrixstats
+ r-phyloseq
+ r-reshape2
+ r-ks
+)
+optdepends=(
+ r-knitr
+ r-rmarkdown
+ r-testthat
+)
+source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('583f058346dcf11a019e5067306427e3aac0377eafd5afba7ada72be924afd6e')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+}
+# vim:set ts=2 sw=2 et: