summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBioArchLinuxBot2023-10-13 12:03:55 +0000
committerBioArchLinuxBot2023-10-13 12:03:55 +0000
commit86d5fa15328d69be28e8ba9092f8c0832d829fd3 (patch)
tree40b6e6969ead52c7efcffd9f3e60d446340aace1
parent3272e2d44dd78788c2c7d38a98e7b6cd42148ec3 (diff)
downloadaur-86d5fa15328d69be28e8ba9092f8c0832d829fd3.tar.gz
[lilac] updated to 1.34.0-2
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD7
2 files changed, 9 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 66ac5338428e..8d56ee5397b8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = r-reticulate
pkgdesc = Interface to 'Python'
pkgver = 1.34.0
- pkgrel = 1
+ pkgrel = 2
url = https://cran.r-project.org/package=reticulate
arch = x86_64
license = Apache
@@ -27,6 +27,8 @@ pkgbase = r-reticulate
depends = r-rcpptoml
depends = r-rlang
depends = r-withr
+ optdepends = ipython: IPython console app
+ optdepends = python-numpy: translation between R matrices and NumPy arrays
optdepends = r-callr
optdepends = r-cli
optdepends = r-glue
diff --git a/PKGBUILD b/PKGBUILD
index c367afed75df..b02867d7df89 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@ _pkgname=reticulate
_pkgver=1.34.0
pkgname=r-${_pkgname,,}
pkgver=${_pkgver//-/.}
-pkgrel=1
+pkgrel=2
pkgdesc="Interface to 'Python'"
arch=(x86_64)
url="https://cran.r-project.org/package=${_pkgname}"
@@ -38,6 +38,8 @@ checkdepends=(
r-testthat
)
optdepends=(
+ "ipython: IPython console app"
+ "python-numpy: translation between R matrices and NumPy arrays"
r-callr
r-cli
r-glue
@@ -53,6 +55,9 @@ sha256sums=('8d0d8922cd811153836e95354357615968b005a4d0d4c5734441953c526e4206')
build() {
mkdir -p build
R CMD INSTALL "$_pkgname" -l build
+
+ # compile python bytecode
+ python -m compileall -o 0 -o 1 -s build -p /usr/lib/R/library "build/$_pkgname/python/rpytools"
}
check() {