summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBioArchLinuxBot2023-08-11 00:07:04 +0000
committerBioArchLinuxBot2023-08-11 00:07:04 +0000
commit98bfab7f4649e75db0cd61b58725ee41a362397c (patch)
tree7e714588bf2881d9c1484c960ebcda376611770f
parent350923cacb56f85410d76e511567e7c9bc217448 (diff)
downloadaur-98bfab7f4649e75db0cd61b58725ee41a362397c.tar.gz
[lilac] updated to 1.31-1
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD19
-rw-r--r--scipy-1.11.0-fixes.patch44
3 files changed, 10 insertions, 66 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 46c091b4222b..74aa8827a5aa 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = r-reticulate
pkgdesc = Interface to 'Python'
- pkgver = 1.30
- pkgrel = 2
+ pkgver = 1.31
+ pkgrel = 1
url = https://cran.r-project.org/package=reticulate
arch = x86_64
license = Apache
@@ -34,11 +34,8 @@ pkgbase = r-reticulate
optdepends = r-pillar
optdepends = r-rmarkdown
optdepends = r-testthat
- source = https://cran.r-project.org/src/contrib/reticulate_1.30.tar.gz
- source = scipy-1.11.0-fixes.patch
- md5sums = 9063282d659c73afbf9bcaec50878eb7
- md5sums = 4247ebf82b55d3bebfdd2f5235d082a7
- sha256sums = ee8f8a3a90fa49faf802c345a23e103d897e40dadc5ec75bfb13ce06576017df
- sha256sums = 943a11211e86181987e726e76801383bef4a433a82d86e953733e14b4e4a796a
+ source = https://cran.r-project.org/src/contrib/reticulate_1.31.tar.gz
+ md5sums = 4f5ac00a8e542fcb6e44148870aeea48
+ sha256sums = 9295ffa2fe6a0861e71f174306e456d371722d54e4da3cacbb65f39e92edd9a7
pkgname = r-reticulate
diff --git a/PKGBUILD b/PKGBUILD
index cec6b336fd3d..ee92db72f414 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,10 +3,10 @@
# Contributor: Robert Greener <me@r0bert.dev>
_pkgname=reticulate
-_pkgver=1.30
+_pkgver=1.31
pkgname=r-${_pkgname,,}
pkgver=${_pkgver//-/.}
-pkgrel=2
+pkgrel=1
pkgdesc="Interface to 'Python'"
arch=(x86_64)
url="https://cran.r-project.org/package=${_pkgname}"
@@ -46,18 +46,9 @@ optdepends=(
r-rmarkdown
r-testthat
)
-source=("https://cran.r-project.org/src/contrib/${_pkgname}_${_pkgver}.tar.gz"
- "scipy-1.11.0-fixes.patch")
-md5sums=('9063282d659c73afbf9bcaec50878eb7'
- '4247ebf82b55d3bebfdd2f5235d082a7')
-sha256sums=('ee8f8a3a90fa49faf802c345a23e103d897e40dadc5ec75bfb13ce06576017df'
- '943a11211e86181987e726e76801383bef4a433a82d86e953733e14b4e4a796a')
-
-prepare() {
- cd "$_pkgname"
- # Fix compatibility with python-scipy 1.11.0 and newer
- patch -Np1 -i ../scipy-1.11.0-fixes.patch
-}
+source=("https://cran.r-project.org/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+md5sums=('4f5ac00a8e542fcb6e44148870aeea48')
+sha256sums=('9295ffa2fe6a0861e71f174306e456d371722d54e4da3cacbb65f39e92edd9a7')
build() {
mkdir -p build
diff --git a/scipy-1.11.0-fixes.patch b/scipy-1.11.0-fixes.patch
deleted file mode 100644
index f3698a38eb2f..000000000000
--- a/scipy-1.11.0-fixes.patch
+++ /dev/null
@@ -1,44 +0,0 @@
-diff --git a/NAMESPACE b/NAMESPACE
-index 6f2d21e4..cde11ac7 100644
---- a/NAMESPACE
-+++ b/NAMESPACE
-@@ -44,6 +44,7 @@ S3method(conditionCall,python.builtin.BaseException)
- S3method(conditionMessage,python.builtin.BaseException)
- S3method(dim,pandas.core.frame.DataFrame)
- S3method(dim,pandas.core.series.Series)
-+S3method(dim,scipy.sparse._base._spbase)
- S3method(dim,scipy.sparse._base.spmatrix)
- S3method(dim,scipy.sparse.base.spmatrix)
- S3method(format,py_config)
-@@ -56,6 +57,7 @@ S3method(length,python.builtin.dict)
- S3method(length,python.builtin.list)
- S3method(length,python.builtin.object)
- S3method(length,python.builtin.tuple)
-+S3method(length,scipy.sparse._base._spbase)
- S3method(length,scipy.sparse._base.spmatrix)
- S3method(length,scipy.sparse.base.spmatrix)
- S3method(names,python.builtin.module)
-@@ -97,6 +99,7 @@ S3method(py_to_r,scipy.sparse._base.spmatrix)
- S3method(py_to_r,scipy.sparse._coo.coo_matrix)
- S3method(py_to_r,scipy.sparse._csc.csc_matrix)
- S3method(py_to_r,scipy.sparse._csr.csr_matrix)
-+S3method(py_to_r,scipy.sparse._matrix.spmatrix)
- S3method(py_to_r,scipy.sparse.base.spmatrix)
- S3method(py_to_r,scipy.sparse.coo.coo_matrix)
- S3method(py_to_r,scipy.sparse.csc.csc_matrix)
-diff --git a/R/conversion.R b/R/conversion.R
-index e819223c..e2d47ec6 100644
---- a/R/conversion.R
-+++ b/R/conversion.R
-@@ -646,3 +646,11 @@ py_to_r.scipy.sparse._csc.csc_matrix <- py_to_r.scipy.sparse.csc.csc_matrix
- py_to_r.scipy.sparse._csr.csr_matrix <- py_to_r.scipy.sparse.csr.csr_matrix
- #' @export
- py_to_r.scipy.sparse._coo.coo_matrix <- py_to_r.scipy.sparse.coo.coo_matrix
-+
-+# updated locations for scipy 1.11.0
-+#' @export
-+dim.scipy.sparse._base._spbase <- dim.scipy.sparse.base.spmatrix
-+#' @export
-+length.scipy.sparse._base._spbase <- length.scipy.sparse.base.spmatrix
-+#' @export
-+py_to_r.scipy.sparse._matrix.spmatrix <- py_to_r.scipy.sparse.base.spmatrix