summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBioArchLinuxBot2024-07-24 12:02:44 +0000
committerBioArchLinuxBot2024-07-24 12:02:44 +0000
commit4ea0d4403515a985afe03a9184d2c5d4218b2cda (patch)
tree304d7baa7effbbdac15f877fa2c529dcd9f3fc1e
parentf3bdbb5cfff3bfe92b4fad0e21db54de7e31d2b5 (diff)
downloadaur-4ea0d4403515a985afe03a9184d2c5d4218b2cda.tar.gz
[lilac] updated to 1.5.4-1
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD18
-rw-r--r--fix-tests.patch45
3 files changed, 66 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e4f97b8835c5..55c95ce479f5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = r-revdbayes
pkgdesc = Ratio-of-Uniforms Sampling for Bayesian Extreme Value Analysis
- pkgver = 1.5.3
- pkgrel = 2
+ pkgver = 1.5.4
+ pkgrel = 1
url = https://cran.r-project.org/package=revdbayes
arch = x86_64
license = GPL-2.0-or-later
@@ -17,8 +17,11 @@ pkgbase = r-revdbayes
optdepends = r-microbenchmark
optdepends = r-rmarkdown
optdepends = r-testthat
- source = https://cran.r-project.org/src/contrib/revdbayes_1.5.3.tar.gz
- md5sums = f19c7af715a6a845ca9a615276bc4603
- b2sums = 19b33bcbf6dc4ab868c70ded29dbebef83e8228105dfe4e71ec6f2c5ca6605e439064c1edce92c883de892eff2a52a360e96f8eba39b96109236a3f84ebbf2be
+ source = https://cran.r-project.org/src/contrib/revdbayes_1.5.4.tar.gz
+ source = fix-tests.patch
+ md5sums = 334f2487c7d1da593e4bd41865fc360e
+ md5sums = dd7ce9091e07ca9a47821e8bcf561b08
+ b2sums = 1d00242d9ffbd39316eed67091524976a3d387845954a5f34f3abf7c4a5848aac8272457a721a895854688354db0f1f553f171252608d3c11d9c3c0ab407e746
+ b2sums = 97d09c073f004e7b1afa24422817e8458534ed643a7b7a9d0dbfc48681fdee0187fcbe3ffc6b713cc5ad541106b055931ffa05be2c1828029f23daa92059371a
pkgname = r-revdbayes
diff --git a/PKGBUILD b/PKGBUILD
index d51e684d15f7..061a45f32e81 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,10 @@
# Maintainer: Pekka Ristola <pekkarr [at] protonmail [dot] com>
_pkgname=revdbayes
-_pkgver=1.5.3
+_pkgver=1.5.4
pkgname=r-${_pkgname,,}
pkgver=${_pkgver//-/.}
-pkgrel=2
+pkgrel=1
pkgdesc="Ratio-of-Uniforms Sampling for Bayesian Extreme Value Analysis"
arch=(x86_64)
url="https://cran.r-project.org/package=$_pkgname"
@@ -29,9 +29,17 @@ optdepends=(
r-rmarkdown
r-testthat
)
-source=("https://cran.r-project.org/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
-md5sums=('f19c7af715a6a845ca9a615276bc4603')
-b2sums=('19b33bcbf6dc4ab868c70ded29dbebef83e8228105dfe4e71ec6f2c5ca6605e439064c1edce92c883de892eff2a52a360e96f8eba39b96109236a3f84ebbf2be')
+source=("https://cran.r-project.org/src/contrib/${_pkgname}_${_pkgver}.tar.gz"
+ "fix-tests.patch")
+md5sums=('334f2487c7d1da593e4bd41865fc360e'
+ 'dd7ce9091e07ca9a47821e8bcf561b08')
+b2sums=('1d00242d9ffbd39316eed67091524976a3d387845954a5f34f3abf7c4a5848aac8272457a721a895854688354db0f1f553f171252608d3c11d9c3c0ab407e746'
+ '97d09c073f004e7b1afa24422817e8458534ed643a7b7a9d0dbfc48681fdee0187fcbe3ffc6b713cc5ad541106b055931ffa05be2c1828029f23daa92059371a')
+
+prepare() {
+ # skip long tests
+ patch -Np1 -i fix-tests.patch
+}
build() {
mkdir build
diff --git a/fix-tests.patch b/fix-tests.patch
new file mode 100644
index 000000000000..609dba33b8a2
--- /dev/null
+++ b/fix-tests.patch
@@ -0,0 +1,45 @@
+diff --git a/revdbayes/tests/testthat/test-rpost_bingp.R b/revdbayes/tests/testthat/test-rpost_bingp.R
+index 8a91d8a..f30090d 100644
+--- a/revdbayes/tests/testthat/test-rpost_bingp.R
++++ b/revdbayes/tests/testthat/test-rpost_bingp.R
+@@ -1,3 +1,4 @@
++skip("long test")
+ #context("binGP: rpost_rcpp vs rpost")
+
+ # We check that the values simulated using rpost() and rpost_rcpp() are
+diff --git a/revdbayes/tests/testthat/test-rpost_gev.R b/revdbayes/tests/testthat/test-rpost_gev.R
+index b1d6877..fd84137 100644
+--- a/revdbayes/tests/testthat/test-rpost_gev.R
++++ b/revdbayes/tests/testthat/test-rpost_gev.R
+@@ -1,3 +1,4 @@
++skip("long test")
+ #context("GEV: rpost_rcpp vs rpost")
+
+ # We check that the values simulated using rpost() and rpost_rcpp() are
+diff --git a/revdbayes/tests/testthat/test-rpost_gp.R b/revdbayes/tests/testthat/test-rpost_gp.R
+index 4bc6b7a..431df87 100644
+--- a/revdbayes/tests/testthat/test-rpost_gp.R
++++ b/revdbayes/tests/testthat/test-rpost_gp.R
+@@ -1,3 +1,4 @@
++skip("long test")
+ #context("GP: rpost_rcpp vs rpost")
+
+ # We check that the values simulated using rpost() and rpost_rcpp() are
+diff --git a/revdbayes/tests/testthat/test-rpost_os.R b/revdbayes/tests/testthat/test-rpost_os.R
+index d4aa9b3..8c87ec4 100644
+--- a/revdbayes/tests/testthat/test-rpost_os.R
++++ b/revdbayes/tests/testthat/test-rpost_os.R
+@@ -1,3 +1,4 @@
++skip("long test")
+ #context("OS: rpost_rcpp vs rpost")
+
+ # We check that the values simulated using rpost() and rpost_rcpp() are
+diff --git a/revdbayes/tests/testthat/test-rpost_pp.R b/revdbayes/tests/testthat/test-rpost_pp.R
+index 14f7946..8761674 100644
+--- a/revdbayes/tests/testthat/test-rpost_pp.R
++++ b/revdbayes/tests/testthat/test-rpost_pp.R
+@@ -1,3 +1,4 @@
++skip("long test")
+ #context("PP: rpost_rcpp vs rpost")
+
+ # We check that the values simulated using rpost() and rpost_rcpp() are