summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBioArchLinuxBot2024-04-26 12:01:54 +0000
committerBioArchLinuxBot2024-04-26 12:01:54 +0000
commit429e3223ecacfa0b4acad85db32a9c9384330cfc (patch)
treefe96bf3d3bfccb53b6e2ac8a31294a854cec3664
parent6a9a89dcafe97d2ade5218a0fc090d298cc4a467 (diff)
downloadaur-429e3223ecacfa0b4acad85db32a9c9384330cfc.tar.gz
[lilac] updated to 2.46.1-2
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD40
-rw-r--r--fix-build.patch28
3 files changed, 63 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f283635a53d3..26e3f49ed20c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,16 @@
pkgbase = r-rhdf5
pkgdesc = R Interface to HDF5
pkgver = 2.46.1
- pkgrel = 1
+ pkgrel = 2
url = https://bioconductor.org/packages/rhdf5
arch = x86_64
- license = Artistic2.0
- depends = r
+ license = Artistic-2.0
+ depends = curl
+ depends = openssl
depends = r-rhdf5filters
depends = r-rhdf5lib
depends = r-s4vectors
+ depends = zlib
optdepends = r-bench
optdepends = r-biocparallel
optdepends = r-biocstyle
@@ -19,10 +21,11 @@ pkgbase = r-rhdf5
optdepends = r-mockery
optdepends = r-rmarkdown
optdepends = r-testthat
- options = !lto
- options = !buildflags
- options = staticlibs
source = https://bioconductor.org/packages/release/bioc/src/contrib/rhdf5_2.46.1.tar.gz
- sha256sums = b68f4960bf8498e83984467b07ed8fa10b3ef68fb5abbc776d6b7dee9307de79
+ source = fix-build.patch
+ md5sums = 947e662fe5f427ed0cc839e8049b431e
+ md5sums = e7763c1284318e623c69572315650118
+ b2sums = 6915bc95d312b394a315b55935c37e6cb4be5f6207eb46ff61c1b2933409d612cccf4920d2cc650e563959c0acfcf3b1421bdd17a72cce18034c7b0f971d0253
+ b2sums = f776cc9e80195b4e4dbfe85e0bf3da4c5dc1967219120072949e847ec725283e74293a71cd51a6d6b57dd54b5f2aae80c4150ba30cb74efdd83fb2b135ae5698
pkgname = r-rhdf5
diff --git a/PKGBUILD b/PKGBUILD
index 9b5333f760d7..6a01d76cbf64 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,21 @@
-# system requirements: GNU make
# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
_pkgname=rhdf5
_pkgver=2.46.1
pkgname=r-${_pkgname,,}
-pkgver=2.46.1
-pkgrel=1
-pkgdesc='R Interface to HDF5'
-arch=('x86_64')
-url="https://bioconductor.org/packages/${_pkgname}"
-license=('Artistic2.0')
+pkgver=${_pkgver//-/.}
+pkgrel=2
+pkgdesc="R Interface to HDF5"
+arch=(x86_64)
+url="https://bioconductor.org/packages/$_pkgname"
+license=('Artistic-2.0')
depends=(
- r
+ curl
+ openssl
r-rhdf5filters
r-rhdf5lib
r-s4vectors
+ zlib
)
optdepends=(
r-bench
@@ -28,15 +29,24 @@ optdepends=(
r-rmarkdown
r-testthat
)
-source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
-sha256sums=('b68f4960bf8498e83984467b07ed8fa10b3ef68fb5abbc776d6b7dee9307de79')
-options=(!lto !buildflags staticlibs)
+source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz"
+ "fix-build.patch")
+md5sums=('947e662fe5f427ed0cc839e8049b431e'
+ 'e7763c1284318e623c69572315650118')
+b2sums=('6915bc95d312b394a315b55935c37e6cb4be5f6207eb46ff61c1b2933409d612cccf4920d2cc650e563959c0acfcf3b1421bdd17a72cce18034c7b0f971d0253'
+ 'f776cc9e80195b4e4dbfe85e0bf3da4c5dc1967219120072949e847ec725283e74293a71cd51a6d6b57dd54b5f2aae80c4150ba30cb74efdd83fb2b135ae5698')
+
+prepare() {
+ # fix format string errors
+ patch -Np1 -i fix-build.patch
+}
+
build() {
- R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+ mkdir build
+ R CMD INSTALL -l build "$_pkgname"
}
package() {
- install -dm0755 "${pkgdir}/usr/lib/R/library"
- cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+ install -d "$pkgdir/usr/lib/R/library"
+ cp -a --no-preserve=ownership "build/$_pkgname" "$pkgdir/usr/lib/R/library"
}
-# vim:set ts=2 sw=2 et:
diff --git a/fix-build.patch b/fix-build.patch
new file mode 100644
index 000000000000..0facb3e5e95f
--- /dev/null
+++ b/fix-build.patch
@@ -0,0 +1,28 @@
+diff --git a/rhdf5/src/H5E.c b/rhdf5/src/H5E.c
+index cbb1388..eac0700 100644
+--- a/rhdf5/src/H5E.c
++++ b/rhdf5/src/H5E.c
+@@ -114,9 +114,9 @@ herr_t _rhdf5PrintErrorR( hid_t estack_id, void * stream) {
+ strcat(str, "\n");
+ strcat(str, client_data.txt[i]);
+ }
+- error(str);
++ error("%s", str);
+ } else if (client_data.n == 1) {
+- error(client_data.txt[0]);
++ error("%s", client_data.txt[0]);
+ } else {
+ error("libhdf5 (no error message captured).");
+ }
+@@ -146,9 +146,9 @@ herr_t _rhdf5PrintErrorRcompact( hid_t estack_id, void * stream) {
+ strcat(str, "\n");
+ strcat(str, client_data.txt[i]);
+ }
+- error(str);
++ error("%s", str);
+ } else if (client_data.n == 1) {
+- error(client_data.txt[0]);
++ error("%s", client_data.txt[0]);
+ } else {
+ error("libhdf5 (no error message captured).");
+ }