summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristoph Fink2022-11-04 19:21:43 +0200
committerChristoph Fink2022-11-04 19:21:43 +0200
commit892c00d161c1684135cba005765e59617edf5eb6 (patch)
tree3964a86b4019aab43a840dac168426e7350f1d04
parent600d38f670fbc314350200e1081c449e2cf5617d (diff)
downloadaur-892c00d161c1684135cba005765e59617edf5eb6.tar.gz
upgpkg: r-rhtslib 2.0.0-1
upstream release
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD43
2 files changed, 32 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 86aed46c028b..3280c13af5e4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,23 +1,19 @@
pkgbase = r-rhtslib
pkgdesc = HTSlib high-throughput sequencing library as an R package
- pkgver = 1.28.0
+ pkgver = 2.0.0
pkgrel = 1
url = https://bioconductor.org/packages/release/bioc/html/Rhtslib.html
arch = i686
arch = x86_64
- license = LGPL2
- makedepends = make
+ license = LGPL2.1
depends = r
depends = r-zlibbioc
- depends = bzip2
- depends = xz
- depends = curl
optdepends = r-knitr
- optdepends = r-rmarkdown
+ optdepends = r-markdown
optdepends = r-biocstyle
options = !lto
options = staticlibs
- source = https://bioconductor.org/packages/release/bioc/src/contrib/Rhtslib_1.28.0.tar.gz
- sha256sums = 4e48c8643e5d3429238ee76faa4c68ed8a7028e7f594c109ee75f5e994d17c1e
+ source = https://bioconductor.org/packages/release/bioc/src/contrib/Rhtslib_2.0.0.tar.gz
+ b2sums = a12733e6d900552b20e8ac9e6bb95d63146ab35dc41bf5e31357795891882333689ca4b8ad94e1007a7c5893c3757c4fb41f0384815c9964d9826b0e2a013bb7
pkgname = r-rhtslib
diff --git a/PKGBUILD b/PKGBUILD
index 41160eec8bfa..717541d6178c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,31 +2,42 @@
# Contributor: Viktor Drobot (aka dviktor) linux776 [at] gmail [dot] com
# Contributor: Grey Christoforo <first name at last name dot net>
+
_bcname=Rhtslib
-_bcver=1.28.0
+_bcver=2.0.0
pkgname=r-${_bcname,,}
-pkgver=${_bcver//[:-]/.}
-pkgrel=1
pkgdesc="HTSlib high-throughput sequencing library as an R package"
-arch=(i686 x86_64)
url="https://bioconductor.org/packages/release/bioc/html/${_bcname}.html"
-license=(LGPL2)
-depends=(r r-zlibbioc bzip2 xz curl)
-makedepends=(make)
-optdepends=(r-knitr r-rmarkdown r-biocstyle)
+license=("LGPL2.1")
+pkgver=${_bcver//[:-]/.}
+pkgrel=1
+
+arch=("i686" "x86_64")
+depends=(
+ "r"
+ "r-zlibbioc"
+)
+optdepends=(
+ "r-knitr"
+ "r-markdown"
+ "r-biocstyle"
+)
+makedepends=()
+
source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_bcname}_${_bcver}.tar.gz")
-sha256sums=('4e48c8643e5d3429238ee76faa4c68ed8a7028e7f594c109ee75f5e994d17c1e')
-options=(!lto staticlibs)
+b2sums=('a12733e6d900552b20e8ac9e6bb95d63146ab35dc41bf5e31357795891882333689ca4b8ad94e1007a7c5893c3757c4fb41f0384815c9964d9826b0e2a013bb7')
+
+options=("!lto" "staticlibs")
build() {
- R CMD INSTALL ${_bcname}_${_bcver}.tar.gz -l "${srcdir}"
+ R CMD INSTALL ${_bcname}_${_bcver}.tar.gz -l "${srcdir}"
}
package() {
- install -dm0755 "${pkgdir}/usr/lib/R/library"
- cp -a --no-preserve=ownership "${_bcname}" "${pkgdir}/usr/lib/R/library"
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_bcname}" "${pkgdir}/usr/lib/R/library"
- if [[ -f "${_cranname}/LICENSE" ]]; then
- install -Dm0644 "${_cranname}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
- fi
+ if [[ -f "${_bcname}/LICENSE" ]]; then
+ install -Dm0644 "${_bcname}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ fi
}