summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGrey Christoforo2019-11-27 14:44:16 +0000
committerGrey Christoforo2019-11-27 14:44:16 +0000
commitd072f29029265f32f4a890c709195462e31ba19e (patch)
tree9bbe8c2db76857fc326f9639d2a72d7f360a8e8b
downloadaur-d072f29029265f32f4a890c709195462e31ba19e.tar.gz
initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD19
3 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bcd029a3848c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = r-rhtslib
+ pkgdesc = high-throughput sequencing library
+ pkgver = 1.18.0
+ pkgrel = 1
+ url = https://bioconductor.org/packages/release/bioc/html/Rhtslib.html
+ arch = x86_64
+ license = LGPL (>= 2)
+ depends = r
+ depends = r-zlibbioc
+ source = https://bioconductor.org/packages/release/bioc/src/contrib/Rhtslib_1.18.0.tar.gz
+ sha1sums = cc264f13d48810127cc86dd798d1da540d02ffed
+
+pkgname = r-rhtslib
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..6ae0b18a1f6c
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/pkg
+/src
+*.tar.gz
+*.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5dad6930f962
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Contributor: Grey Christoforo <first name at last name dot net>
+pkgname=r-rhtslib
+_bc_name=Rhtslib
+pkgver=1.18.0
+pkgrel=1
+pkgdesc="high-throughput sequencing library"
+url="https://bioconductor.org/packages/release/bioc/html/${_bc_name}.html"
+arch=("x86_64")
+license=('LGPL (>= 2)')
+depends=('r' 'r-zlibbioc')
+source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_bc_name}_${pkgver}.tar.gz")
+sha1sums=('cc264f13d48810127cc86dd798d1da540d02ffed')
+
+package() {
+ mkdir -p $pkgdir/usr/lib/R/library
+ cd $srcdir
+
+ R CMD INSTALL -l $pkgdir/usr/lib/R/library ./${_bc_name}
+}