summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBioArchLinuxBot2024-01-25 18:03:09 +0000
committerBioArchLinuxBot2024-01-25 18:03:09 +0000
commit19ded1c96b43ec1ae9b20c8368dde8a2372887d9 (patch)
treec1f6a8b9fcdc82b32dfea4d595e58501263d3860
parent7b0ec99a6ab7df52693ed8fd4e6d81ac7b9abb92 (diff)
downloadaur-19ded1c96b43ec1ae9b20c8368dde8a2372887d9.tar.gz
[lilac] updated to 1.2.0-3
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD17
2 files changed, 14 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5b3a7d6ff6b2..310a2ddb25b4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,10 @@
pkgbase = r-rificomparative
- pkgdesc = 'rifiComparative' compares the output of rifi from two different conditions.
+ pkgdesc = 'rifiComparative' compares the output of rifi from two different conditions
pkgver = 1.2.0
- pkgrel = 1
+ pkgrel = 3
url = https://bioconductor.org/packages/rifiComparative
arch = any
- license = GPL3
+ license = GPL-3.0-only AND MIT
depends = r-cowplot
depends = r-devtools
depends = r-domc
@@ -30,6 +30,6 @@ pkgbase = r-rificomparative
optdepends = r-rmarkdown
source = https://bioconductor.org/packages/release/bioc/src/contrib/rifiComparative_1.2.0.tar.gz
md5sums = d371dc0f2b156f4565b09b7cfa5406e0
- sha256sums = 3175cb710dd786c8c2d3d9f2067c86f253d8023548c6e2664393a656308e7e99
+ b2sums = 4b0d7fdd702f24739a603f19abb6407a89354589c9d58942ae07aef03e1a8e31cb0bf206aca26a0cbb47da2d1d4369ef3e6221efdc534b6803b9d5e3ab4ec03a
pkgname = r-rificomparative
diff --git a/PKGBUILD b/PKGBUILD
index 2d122e99de75..acf642be7b36 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,11 +4,11 @@ _pkgname=rifiComparative
_pkgver=1.2.0
pkgname=r-${_pkgname,,}
pkgver=${_pkgver//-/.}
-pkgrel=1
-pkgdesc="'rifiComparative' compares the output of rifi from two different conditions."
+pkgrel=3
+pkgdesc="'rifiComparative' compares the output of rifi from two different conditions"
arch=(any)
-url="https://bioconductor.org/packages/${_pkgname}"
-license=(GPL3)
+url="https://bioconductor.org/packages/$_pkgname"
+license=('GPL-3.0-only AND MIT')
depends=(
r-cowplot
r-devtools
@@ -38,14 +38,17 @@ optdepends=(
)
source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
md5sums=('d371dc0f2b156f4565b09b7cfa5406e0')
-sha256sums=('3175cb710dd786c8c2d3d9f2067c86f253d8023548c6e2664393a656308e7e99')
+b2sums=('4b0d7fdd702f24739a603f19abb6407a89354589c9d58942ae07aef03e1a8e31cb0bf206aca26a0cbb47da2d1d4369ef3e6221efdc534b6803b9d5e3ab4ec03a')
build() {
- mkdir -p build
- R CMD INSTALL "$_pkgname" -l build
+ mkdir build
+ R CMD INSTALL -l build "$_pkgname"
}
package() {
install -d "$pkgdir/usr/lib/R/library"
cp -a --no-preserve=ownership "build/$_pkgname" "$pkgdir/usr/lib/R/library"
+
+ install -d "$pkgdir/usr/share/licenses/$pkgname"
+ ln -s "/usr/lib/R/library/$_pkgname/LICENSE" "$pkgdir/usr/share/licenses/$pkgname"
}