summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPekka Ristola2023-11-10 13:38:45 +0200
committerPekka Ristola2023-11-10 13:38:45 +0200
commit7b0ec99a6ab7df52693ed8fd4e6d81ac7b9abb92 (patch)
treeaa7716532b146544648408d7de14aa7a6a07634d
downloadaur-7b0ec99a6ab7df52693ed8fd4e6d81ac7b9abb92.tar.gz
Version 1.2.0
-rw-r--r--.SRCINFO35
-rw-r--r--PKGBUILD51
2 files changed, 86 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5b3a7d6ff6b2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,35 @@
+pkgbase = r-rificomparative
+ pkgdesc = 'rifiComparative' compares the output of rifi from two different conditions.
+ pkgver = 1.2.0
+ pkgrel = 1
+ url = https://bioconductor.org/packages/rifiComparative
+ arch = any
+ license = GPL3
+ depends = r-cowplot
+ depends = r-devtools
+ depends = r-domc
+ depends = r-dplyr
+ depends = r-dta
+ depends = r-egg
+ depends = r-foreach
+ depends = r-ggplot2
+ depends = r-ggrepel
+ depends = r-lsd
+ depends = r-reshape2
+ depends = r-rlang
+ depends = r-rtracklayer
+ depends = r-s4vectors
+ depends = r-scales
+ depends = r-stringr
+ depends = r-summarizedexperiment
+ depends = r-tibble
+ depends = r-writexl
+ optdepends = r-biocstyle
+ optdepends = r-desctools
+ optdepends = r-knitr
+ optdepends = r-rmarkdown
+ source = https://bioconductor.org/packages/release/bioc/src/contrib/rifiComparative_1.2.0.tar.gz
+ md5sums = d371dc0f2b156f4565b09b7cfa5406e0
+ sha256sums = 3175cb710dd786c8c2d3d9f2067c86f253d8023548c6e2664393a656308e7e99
+
+pkgname = r-rificomparative
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2d122e99de75
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,51 @@
+# Maintainer: Pekka Ristola <pekkarr [at] protonmail [dot] com>
+
+_pkgname=rifiComparative
+_pkgver=1.2.0
+pkgname=r-${_pkgname,,}
+pkgver=${_pkgver//-/.}
+pkgrel=1
+pkgdesc="'rifiComparative' compares the output of rifi from two different conditions."
+arch=(any)
+url="https://bioconductor.org/packages/${_pkgname}"
+license=(GPL3)
+depends=(
+ r-cowplot
+ r-devtools
+ r-domc
+ r-dplyr
+ r-dta
+ r-egg
+ r-foreach
+ r-ggplot2
+ r-ggrepel
+ r-lsd
+ r-reshape2
+ r-rlang
+ r-rtracklayer
+ r-s4vectors
+ r-scales
+ r-stringr
+ r-summarizedexperiment
+ r-tibble
+ r-writexl
+)
+optdepends=(
+ r-biocstyle
+ r-desctools
+ r-knitr
+ r-rmarkdown
+)
+source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+md5sums=('d371dc0f2b156f4565b09b7cfa5406e0')
+sha256sums=('3175cb710dd786c8c2d3d9f2067c86f253d8023548c6e2664393a656308e7e99')
+
+build() {
+ mkdir -p build
+ R CMD INSTALL "$_pkgname" -l build
+}
+
+package() {
+ install -d "$pkgdir/usr/lib/R/library"
+ cp -a --no-preserve=ownership "build/$_pkgname" "$pkgdir/usr/lib/R/library"
+}