summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBioArchLinuxBot2024-03-06 00:04:44 +0000
committerBioArchLinuxBot2024-03-06 00:04:44 +0000
commit90ae93f02a79e7aebf01f4b8a746f0a0ded497b5 (patch)
tree5b8a0204f6e52df4ed10e5ebbe6d3ec58da5642f
parente35e96f994abf133639b41c091768b247d3965e7 (diff)
downloadaur-90ae93f02a79e7aebf01f4b8a746f0a0ded497b5.tar.gz
[lilac] updated to 2.26-1
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD15
2 files changed, 12 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a27feea03fa6..a6cd3a7070e4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,10 @@
pkgbase = r-rmarkdown
pkgdesc = Dynamic Documents for R
- pkgver = 2.25
+ pkgver = 2.26
pkgrel = 1
url = https://cran.r-project.org/package=rmarkdown
arch = any
- license = GPL3
+ license = GPL-3.0-only
checkdepends = r-curl
checkdepends = r-shiny
checkdepends = r-testthat
@@ -19,7 +19,6 @@ pkgbase = r-rmarkdown
depends = r-jquerylib
depends = r-jsonlite
depends = r-knitr
- depends = r-stringr
depends = r-tinytex
depends = r-xfun
depends = r-yaml
@@ -36,8 +35,8 @@ pkgbase = r-rmarkdown
optdepends = r-tibble
optdepends = r-vctrs
optdepends = r-withr
- source = https://cran.r-project.org/src/contrib/rmarkdown_2.25.tar.gz
- md5sums = c30424fc39406007031cf4e62ea572a8
- sha256sums = 06e4662666fe018fbe3bef3531280a461c7bc24bb00f34b9d4c7b08d52210155
+ source = https://cran.r-project.org/src/contrib/rmarkdown_2.26.tar.gz
+ md5sums = d4f5e42ce1e7d2ab04fb1beff82c4ff5
+ b2sums = 787c2e0505c07345cc1e20826ca1a85d8fabc58a0468f76d7fb0e5d2a555168913afa0fca38fad5d7359c1fb6f0bcb44fdddbd9f2686a828c0e7d8f3818f829f
pkgname = r-rmarkdown
diff --git a/PKGBUILD b/PKGBUILD
index e21524be3e5c..3e556fb892eb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,14 +7,14 @@
# Contributor: Alex Branham <branham@utexas.edu>
_pkgname=rmarkdown
-_pkgver=2.25
+_pkgver=2.26
pkgname=r-${_pkgname,,}
pkgver=${_pkgver//-/.}
pkgrel=1
pkgdesc="Dynamic Documents for R"
arch=(any)
-url="https://cran.r-project.org/package=${_pkgname}"
-license=(GPL3)
+url="https://cran.r-project.org/package=$_pkgname"
+license=('GPL-3.0-only')
depends=(
pandoc
r-bslib
@@ -24,7 +24,6 @@ depends=(
r-jquerylib
r-jsonlite
r-knitr
- r-stringr
r-tinytex
r-xfun
r-yaml
@@ -53,8 +52,8 @@ optdepends=(
r-withr
)
source=("https://cran.r-project.org/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
-md5sums=('c30424fc39406007031cf4e62ea572a8')
-sha256sums=('06e4662666fe018fbe3bef3531280a461c7bc24bb00f34b9d4c7b08d52210155')
+md5sums=('d4f5e42ce1e7d2ab04fb1beff82c4ff5')
+b2sums=('787c2e0505c07345cc1e20826ca1a85d8fabc58a0468f76d7fb0e5d2a555168913afa0fca38fad5d7359c1fb6f0bcb44fdddbd9f2686a828c0e7d8f3818f829f')
prepare() {
# Skip a test that might fail depending on environment
@@ -63,8 +62,8 @@ prepare() {
}
build() {
- mkdir -p build
- R CMD INSTALL "$_pkgname" -l build
+ mkdir build
+ R CMD INSTALL -l build "$_pkgname"
}
check() {