summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlex Branham2018-05-30 09:10:53 -0500
committerAlex Branham2018-05-30 09:10:53 -0500
commit968f753a08fac0b541e68c9a0edeeb60e1d217d8 (patch)
tree0d8ab19901e4b23ad2b4a0c0883b7a521271994e
downloadaur-968f753a08fac0b541e68c9a0edeeb60e1d217d8.tar.gz
Initial commit
-rw-r--r--.SRCINFO28
-rw-r--r--PKGBUILD26
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9ceb35ee4172
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
+pkgbase = r-rmarkdown
+ pkgdesc = Dynamic Documents for R
+ pkgver = 1.9
+ pkgrel = 1
+ url = https://cran.r-project.org/web/packages/rmarkdown/index.html
+ arch = any
+ license = GPL3
+ depends = r
+ depends = r-knitr
+ depends = r-yaml
+ depends = r-htmltools
+ depends = r-evaluate
+ depends = r-base64enc
+ depends = r-jsonlite
+ depends = r-rprojroot
+ depends = r-mime
+ depends = r-stringr
+ optdepends = r-tinytex
+ optdepends = r-shiny
+ optdepends = r-tufte
+ optdepends = r-testthat
+ optdepends = r-digest
+ optdepends = r-cran-tibble
+ source = https://cran.r-project.org/src/contrib/rmarkdown_1.9.tar.gz
+ md5sums = c70c29545cc7af6c907a8dedec7aa7ce
+
+pkgname = r-rmarkdown
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0ec36b63f976
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Alex Branham <branham@utexas.edu>
+_cranname=rmarkdown
+_cranver=1.9
+_pkgtar=${_cranname}_${_cranver}.tar.gz
+pkgname=r-rmarkdown
+pkgver=${_cranver//[:-]/.}
+pkgrel=1
+pkgdesc="Dynamic Documents for R"
+arch=('any')
+url="https://cran.r-project.org/web/packages/${_cranname}/index.html"
+license=('GPL3')
+depends=('r' 'r-knitr' 'r-yaml' 'r-htmltools' 'r-evaluate' 'r-base64enc' 'r-jsonlite' 'r-rprojroot' 'r-mime' 'r-stringr')
+
+optdepends=('r-tinytex' 'r-shiny' 'r-tufte' 'r-testthat' 'r-digest' 'r-cran-tibble')
+
+source=("https://cran.r-project.org/src/contrib/${_pkgtar}")
+md5sums=('c70c29545cc7af6c907a8dedec7aa7ce')
+
+build(){
+ R CMD INSTALL ${_pkgtar} -l $srcdir
+}
+package() {
+ install -d "$pkgdir/usr/lib/R/library"
+ cp -r "$srcdir/$_cranname" "$pkgdir/usr/lib/R/library"
+}
+