summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSukanka2022-06-06 21:14:28 +0800
committerSukanka2022-06-06 21:14:28 +0800
commit2f4235f0404b947470d4d1b1b65fc1e09311a436 (patch)
tree06c29ad3351d6b664f8ec9dceaafbd9f7098cb7b
downloadaur-2f4235f0404b947470d4d1b1b65fc1e09311a436.tar.gz
add r-rnexml
-rw-r--r--.SRCINFO37
-rw-r--r--PKGBUILD54
2 files changed, 91 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4dce8c84bb34
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,37 @@
+pkgbase = r-rnexml
+ pkgdesc = Semantically Rich I/O for the 'NeXML' Format
+ pkgver = 2.4.7
+ pkgrel = 3
+ url = https://cran.r-project.org/package=RNeXML
+ arch = any
+ license = BSD
+ depends = r
+ depends = r-ape
+ depends = r-dplyr
+ depends = r-httr
+ depends = r-lazyeval
+ depends = r-plyr
+ depends = r-reshape2
+ depends = r-stringi
+ depends = r-stringr
+ depends = r-tidyr
+ depends = r-uuid
+ depends = r-xml
+ depends = r-xml2
+ optdepends = r-covr
+ optdepends = r-geiger
+ optdepends = r-knitcitations
+ optdepends = r-knitr
+ optdepends = r-phytools
+ optdepends = r-rdflib
+ optdepends = r-rfigshare
+ optdepends = r-rlang
+ optdepends = r-rmarkdown
+ optdepends = r-spelling
+ optdepends = r-taxadb
+ optdepends = r-testthat
+ optdepends = r-xslt
+ source = https://cran.r-project.org/src/contrib/RNeXML_2.4.7.tar.gz
+ sha256sums = cb311d6dda33a95521a6df360a2d2f4e6d6bc6b330ac5e19ea721ca665bce6fe
+
+pkgname = r-rnexml
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7cd14460bfa8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,54 @@
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=RNeXML
+_pkgver=2.4.7
+pkgname=r-${_pkgname,,}
+pkgver=2.4.7
+pkgrel=3
+pkgdesc="Semantically Rich I/O for the 'NeXML' Format"
+arch=('any')
+url="https://cran.r-project.org/package=${_pkgname}"
+license=('BSD')
+depends=(
+ r
+ r-ape
+ r-dplyr
+ r-httr
+ r-lazyeval
+ r-plyr
+ r-reshape2
+ r-stringi
+ r-stringr
+ r-tidyr
+ r-uuid
+ r-xml
+ r-xml2
+)
+optdepends=(
+ r-covr
+ r-geiger
+ r-knitcitations
+ r-knitr
+ r-phytools
+ r-rdflib
+ r-rfigshare
+ r-rlang
+ r-rmarkdown
+ r-spelling
+ r-taxadb
+ r-testthat
+ r-xslt
+)
+source=("https://cran.r-project.org/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('cb311d6dda33a95521a6df360a2d2f4e6d6bc6b330ac5e19ea721ca665bce6fe')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+ install -Dm644 "${_pkgname}/LICENSE" -t "${pkgdir}/usr/share/licenses/${pkgname}"
+}
+# vim:set ts=2 sw=2 et: