summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorViktor Drobot2022-01-18 22:05:34 +0300
committerViktor Drobot2022-01-18 22:05:34 +0300
commitcaa2c7d8cb19679b540acbef4f4e561fa284fa78 (patch)
tree57ad2234323cfc95cdb05bafd0c0f9c0565c7bb0
parent09cc3fc67a21e598ad965fef72216a7adfc242f7 (diff)
downloadaur-caa2c7d8cb19679b540acbef4f4e561fa284fa78.tar.gz
Fix PKGBUILD
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD11
2 files changed, 5 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e8b545b68456..6dcaf3879d51 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -5,8 +5,7 @@ pkgbase = r-roxygen2
url = https://cran.r-project.org/package=roxygen2
arch = i686
arch = x86_64
- license = GPL2
- license = GPL3
+ license = MIT
depends = r>=3.3
depends = r-brew
depends = r-commonmark
diff --git a/PKGBUILD b/PKGBUILD
index 8900f11d510e..072c40d186de 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,4 @@
-# Maintainer: Viktor Drobot (aka dviktor) linux776 [at] gmail [dot] com
+# Contributor: Viktor Drobot (aka dviktor) linux776 [at] gmail [dot] com
# Contributor: Alex Branham <branham@utexas.edu>
_cranname=roxygen2
@@ -9,21 +9,18 @@ pkgrel=1
pkgdesc="In-Line Documentation for R"
arch=(i686 x86_64)
url="https://cran.r-project.org/package=${_cranname}"
-license=(GPL2 GPL3)
+license=(MIT)
depends=('r>=3.3' r-brew r-commonmark 'r-desc>=1.2.0' r-digest r-knitr 'r-pkgload>=1.0.2' 'r-purrr>=0.3.3' 'r-r6>=2.1.2' r-rlang r-stringi 'r-stringr>=1.0.0' r-xml2 r-cpp11)
optdepends=(r-covr r-devtools r-rmarkdown r-testthat r-r.methodss3 r-r.oo)
source=("https://cran.r-project.org/src/contrib/${_cranname}_${_cranver}.tar.gz")
sha256sums=('b3693d1eb57bb1c27134447ea7f64c353c085dd2237af7cfacc75fca3d2fc5fd')
build() {
- cd "${srcdir}"
-
- R CMD INSTALL ${_cranname}_${_cranver}.tar.gz -l ${srcdir}
+ R CMD INSTALL ${_cranname}_${_cranver}.tar.gz -l "${srcdir}"
}
package() {
- cd "${srcdir}"
-
install -dm0755 "${pkgdir}/usr/lib/R/library"
+
cp -a --no-preserve=ownership "${_cranname}" "${pkgdir}/usr/lib/R/library"
}