summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlex Branham2018-05-30 09:28:41 -0500
committerAlex Branham2018-05-30 09:28:41 -0500
commit1331d3d4a8536cbe3112a296bc9a1ce0e24c0ca1 (patch)
tree8b6c6985ecf06e19a4ac5bf1635a1d3287bd78f7
downloadaur-1331d3d4a8536cbe3112a296bc9a1ce0e24c0ca1.tar.gz
Initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD26
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a2f7325c36fa
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = r-rprojroot
+ pkgdesc = Finding Files in Project Subdirectories
+ pkgver = 1.3.2
+ pkgrel = 1
+ url = https://cran.r-project.org/web/packages/rprojroot/index.html
+ arch = any
+ license = GPL3
+ depends = r
+ depends = r-backports
+ optdepends = r-testthat
+ optdepends = r-mockr
+ optdepends = r-knitr
+ optdepends = r-withr
+ optdepends = r-rmarkdown
+ source = https://cran.r-project.org/src/contrib/rprojroot_1.3-2.tar.gz
+ md5sums = 030a1d238d41ee1e5e21e55eba8403b2
+
+pkgname = r-rprojroot
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e778cdd00410
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Alex Branham <branham@utexas.edu>
+_cranname=rprojroot
+_cranver=1.3-2
+_pkgtar=${_cranname}_${_cranver}.tar.gz
+pkgname=r-rprojroot
+pkgver=${_cranver//[:-]/.}
+pkgrel=1
+pkgdesc="Finding Files in Project Subdirectories"
+arch=('any')
+url="https://cran.r-project.org/web/packages/${_cranname}/index.html"
+license=('GPL3')
+depends=('r' 'r-backports')
+
+optdepends=('r-testthat' 'r-mockr' 'r-knitr' 'r-withr' 'r-rmarkdown')
+
+source=("https://cran.r-project.org/src/contrib/${_pkgtar}")
+md5sums=('030a1d238d41ee1e5e21e55eba8403b2')
+
+build(){
+ R CMD INSTALL ${_pkgtar} -l $srcdir
+}
+package() {
+ install -d "$pkgdir/usr/lib/R/library"
+ cp -r "$srcdir/$_cranname" "$pkgdir/usr/lib/R/library"
+}
+