summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSukanka2022-06-06 21:35:25 +0800
committerSukanka2022-06-06 21:35:25 +0800
commitbf70af4df62a82f919881dc28bd1cf8eaf07d711 (patch)
treede951c7b4b0821e36fca640b2fa78d1a4edd7293
downloadaur-bf70af4df62a82f919881dc28bd1cf8eaf07d711.tar.gz
add r-rsnns
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD31
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..473058a6bb08
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = r-rsnns
+ pkgdesc = Neural Networks using the Stuttgart Neural Network Simulator (SNNS)
+ pkgver = 0.4.14
+ pkgrel = 4
+ url = https://cran.r-project.org/package=RSNNS
+ arch = x86_64
+ license = LGPL
+ depends = r
+ depends = r-rcpp
+ optdepends = r-neuralnettools
+ optdepends = r-scatterplot3d
+ source = https://cran.r-project.org/src/contrib/RSNNS_0.4-14.tar.gz
+ sha256sums = 7f6262cb2b49b5d5979ccce9ded9cbb2c0b348fd7c9eabc1ea1d31c51a102c20
+
+pkgname = r-rsnns
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7de4cbe01912
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=RSNNS
+_pkgver=0.4-14
+pkgname=r-${_pkgname,,}
+pkgver=0.4.14
+pkgrel=4
+pkgdesc='Neural Networks using the Stuttgart Neural Network Simulator (SNNS)'
+arch=('x86_64')
+url="https://cran.r-project.org/package=${_pkgname}"
+license=('LGPL')
+depends=(
+ r
+ r-rcpp
+)
+optdepends=(
+ r-neuralnettools
+ r-scatterplot3d
+)
+source=("https://cran.r-project.org/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('7f6262cb2b49b5d5979ccce9ded9cbb2c0b348fd7c9eabc1ea1d31c51a102c20')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+}
+# vim:set ts=2 sw=2 et: