summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristoph Fink2023-03-26 19:02:34 +0300
committerChristoph Fink2023-03-26 19:02:34 +0300
commit1e93586a32359a4e9a90706d1d4d4953e456bb47 (patch)
treef23e7071f057909913cea42c0f45e1703804a86a
parent017c6fff529f16111b014a0ca1f29ad5a321afa5 (diff)
downloadaur-1e93586a32359a4e9a90706d1d4d4953e456bb47.tar.gz
upgpkg: r-rstudioapi 0.14-3
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD33
2 files changed, 25 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index eb7deb1a3eba..fb723225daae 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,10 @@
pkgbase = r-rstudioapi
pkgdesc = Safely Access the RStudio API
pkgver = 0.14
- pkgrel = 2
+ pkgrel = 3
url = https://cran.r-project.org/package=rstudioapi
arch = any
license = MIT
- checkdepends = r-clipr
- checkdepends = r-covr
- checkdepends = r-knitr
- checkdepends = r-rmarkdown
- checkdepends = r-testthat
depends = r
optdepends = r-clipr
optdepends = r-covr
diff --git a/PKGBUILD b/PKGBUILD
index 46a5e7a23c2b..bc5ddb2a53ca 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,7 +9,7 @@ pkgdesc="Safely Access the RStudio API"
url="https://cran.r-project.org/package=${_cranname}"
license=("MIT")
pkgver=${_cranver//[:-]/.}
-pkgrel=2
+pkgrel=3
arch=("any")
depends=(
@@ -21,10 +21,25 @@ optdepends=(
"r-knitr"
"r-rmarkdown"
)
-checkdepends=(
- "${optdepends[@]}"
- "r-testthat"
-)
+
+# The unittests for `r-rstudioapi` have multiple circular
+# dependency chains.
+
+# As such, the tests can not be run on first build.
+# While R packages from CRAN, generally, are well-tested
+# before they are released, in some situations, you want to
+# have thorough testing on your own end.
+
+# To run the tests, first build this package without `check()`
+# (i.e., as-is) to bootstrap `r-rstudioapi`. Then, on subsequent builds,
+# (assumining you have a local repository that is accessible from
+# the build chroot), uncomment the lines defining `checkdepends`, below,
+# as well as the `check()` function further down
+
+# checkdepends=(
+# "${optdepends[@]}"
+# "r-testthat"
+# )
source=("https://cran.r-project.org/src/contrib/${_cranname}_${_cranver}.tar.gz")
b2sums=("bb969a080d783a7f5003fb5545a37978f9fc0d6fde1e1f4d3d5b5661e14ebaa422785d103d177aff5fee0c328f5e7dc3b524f1213971d9166f52e99d1675091b")
@@ -34,14 +49,14 @@ build() {
R CMD INSTALL ${_cranname}_${_cranver}.tar.gz -l "${srcdir}/build/"
}
-check() {
- R_LIBS="build/" R CMD check --no-manual --as-cran "${_cranname}"
-}
+# check() {
+# export R_LIBS="build/"
+# R CMD check --no-manual "${_cranname}"
+# }
package() {
install -dm0755 "${pkgdir}/usr/lib/R/library"
cp -a --no-preserve=ownership "${srcdir}/build/${_cranname}" "${pkgdir}/usr/lib/R/library"
-
if [[ -f "${_cranname}/LICENSE" ]]; then
install -Dm0644 "${_cranname}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
fi