summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBioArchLinuxBot2024-04-10 12:11:43 +0000
committerBioArchLinuxBot2024-04-10 12:11:43 +0000
commitcacc27660a947735b1b89109c325861cacd2e661 (patch)
tree7cc50e17e5d14b399f74cf3cd5b14f8074ec6384
parent5388ca63263734e7366cbe83f0bbdb7e0c90fc3d (diff)
downloadaur-cacc27660a947735b1b89109c325861cacd2e661.tar.gz
[lilac] updated to 2.2.2.4-2
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD27
2 files changed, 18 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e282727e066b..8b0426ec27c4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,12 @@
pkgbase = r-runjags
pkgdesc = Interface Utilities, Model Templates, Parallel Computing Methods and Additional Distributions for MCMC Models in JAGS
pkgver = 2.2.2.4
- pkgrel = 1
+ pkgrel = 2
url = https://cran.r-project.org/package=runjags
arch = x86_64
- license = GPL
- depends = r
- depends = r-coda
+ license = GPL-2.0-only
depends = jags
+ depends = r-coda
optdepends = r-knitr
optdepends = r-markdown
optdepends = r-modeest
@@ -15,6 +14,7 @@ pkgbase = r-runjags
optdepends = r-spelling
optdepends = r-testthat
source = https://cran.r-project.org/src/contrib/runjags_2.2.2-4.tar.gz
- sha256sums = 6f656e4d0620c0806e596ddb4bfec3934534ec17c02da699fcbfd6720a6f424f
+ md5sums = 0c6bbf7794879f2a345929252d83041c
+ b2sums = 787baaf661a16f97f27f721db8a7c7bf040798d53411c09a037b815149906d5f627c5af8b857eeb80f24540c33d2008970b3f426e3bfd7d88b647cc65d98e05a
pkgname = r-runjags
diff --git a/PKGBUILD b/PKGBUILD
index 5947097715c0..11271a817927 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,17 @@
-# system requirements: JAGS >= 4.3.0 (https://mcmc-jags.sourceforge.io/)
# Maintainer: sukanka <su975853527@gmail.com>
_pkgname=runjags
_pkgver=2.2.2-4
pkgname=r-${_pkgname,,}
-pkgver=2.2.2.4
-pkgrel=1
-pkgdesc='Interface Utilities, Model Templates, Parallel Computing Methods and Additional Distributions for MCMC Models in JAGS'
-arch=('x86_64')
-url="https://cran.r-project.org/package=${_pkgname}"
-license=('GPL')
+pkgver=${_pkgver//-/.}
+pkgrel=2
+pkgdesc="Interface Utilities, Model Templates, Parallel Computing Methods and Additional Distributions for MCMC Models in JAGS"
+arch=(x86_64)
+url="https://cran.r-project.org/package=$_pkgname"
+license=('GPL-2.0-only')
depends=(
- r
- r-coda
jags
+ r-coda
)
optdepends=(
r-knitr
@@ -24,14 +22,15 @@ optdepends=(
r-testthat
)
source=("https://cran.r-project.org/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
-sha256sums=('6f656e4d0620c0806e596ddb4bfec3934534ec17c02da699fcbfd6720a6f424f')
+md5sums=('0c6bbf7794879f2a345929252d83041c')
+b2sums=('787baaf661a16f97f27f721db8a7c7bf040798d53411c09a037b815149906d5f627c5af8b857eeb80f24540c33d2008970b3f426e3bfd7d88b647cc65d98e05a')
build() {
- R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+ mkdir build
+ R CMD INSTALL -l build "$_pkgname"
}
package() {
- install -dm0755 "${pkgdir}/usr/lib/R/library"
- cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+ install -d "$pkgdir/usr/lib/R/library"
+ cp -a --no-preserve=ownership "build/$_pkgname" "$pkgdir/usr/lib/R/library"
}
-# vim:set ts=2 sw=2 et: