summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCsonka Mihaly2019-05-02 19:36:29 +0200
committerCsonka Mihaly2019-05-02 19:36:29 +0200
commita375ab18e3ec0c467028a61473483b24cb79968c (patch)
treea06802ba081e4f36a77c8390ecb1ec1019dee2fa
downloadaur-a375ab18e3ec0c467028a61473483b24cb79968c.tar.gz
Initial release package 20190502
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD27
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..066a38302c5a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = r-rustinr
+ pkgdesc = Rust and R Integration.
+ pkgver = r214.9996184
+ pkgrel = 1
+ url = https://github.com/rustr/rustinr
+ arch = any
+ license = Apache License 2.0
+ makedepends = git
+ makedepends = r-develtools
+ depends = r
+ depends = rustup
+ optdepends = r-testthat
+ provides = r-rustinr
+ conflicts = r-rustinr
+ source = r-rustinr::git+https://github.com/rustr/rustinr.git
+ md5sums = SKIP
+
+pkgname = r-rustinr
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0e545fd4b7e4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Kibouo <csonka.mihaly@hotmail.com>
+pkgname=r-rustinr
+pkgver=r214.9996184
+pkgrel=1
+pkgdesc='Rust and R Integration.'
+arch=('any')
+url='https://github.com/rustr/rustinr'
+license=('Apache License 2.0')
+depends=('r' 'rustup')
+optdepends=('r-testthat')
+makedepends=('git' 'r-develtools')
+provides=("${pkgname}")
+conflicts=("${pkgname}")
+source=("${pkgname}::git+https://github.com/rustr/rustinr.git")
+md5sums=('SKIP')
+pkgver() {
+ cd "${pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+build(){
+ R CMD build rustinr
+ R CMD INSTALL rustinr_*.tar.gz -l $srcdir
+}
+package() {
+ install -d "$pkgdir/usr/lib/R/library"
+ cp -r "$srcdir"/rustinr "$pkgdir/usr/lib/R/library"
+}